summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Lane2024-01-23 19:03:20 +0000
committerChris Lane2024-01-23 19:03:20 +0000
commitb0e4f8565d8286b1e66da87d997c1629b04d3036 (patch)
treed7b887057cbc3f3cefd7a3dabd7f168af30ca4a4
parentead640dafa657eb6e60da540a4deb5b9425b200d (diff)
downloadaur-b0e4f8565d8286b1e66da87d997c1629b04d3036.tar.gz
Rename and tidy package
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18e587789875..622f4b8f676c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
-pkgbase = instant-markdown-d
+pkgbase = nodejs-instant-markdown-d
pkgdesc = Small instant Markdown preview server
pkgver = 0.3.0
pkgrel = 1
url = https://github.com/instant-markdown/instant-markdown-d
arch = any
- license = APACHE
+ license = Apache-2.0
makedepends = npm
depends = nodejs
noextract = instant-markdown-d-0.3.0.tgz
source = https://registry.npmjs.org/instant-markdown-d/-/instant-markdown-d-0.3.0.tgz
sha512sums = 867f89c85a4e9b0045000dea375eda2bb84ca4d337ff7fddaa7f2194c667ca59202025e7d06fa2091b89a3c4e0616c33c9d8ac067c1bfdc010f28871a248eb39
-pkgname = instant-markdown-d
+pkgname = nodejs-instant-markdown-d
diff --git a/PKGBUILD b/PKGBUILD
index 6b4cf38fec5c..abdd8ebfb08d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,23 @@
# Maintainer: Chris Lane <aur at chrislane dot com>
-_npmver=0.3.0
-pkgname=instant-markdown-d
+_pkgname=instant-markdown-d
+pkgname="nodejs-$_pkgname"
pkgver=0.3.0
pkgrel=1
pkgdesc='Small instant Markdown preview server'
arch=('any')
url='https://github.com/instant-markdown/instant-markdown-d'
-license=('APACHE')
+license=('Apache-2.0')
depends=('nodejs')
makedepends=('npm')
optdepends=()
-source=("https://registry.npmjs.org/${pkgname}/-/${pkgname}-${_npmver}.tgz")
-noextract=("${pkgname}-${_npmver}.tgz")
+source=("https://registry.npmjs.org/$_pkgname/-/$_pkgname-$pkgver.tgz")
+noextract=("$_pkgname-$pkgver.tgz")
sha512sums=('867f89c85a4e9b0045000dea375eda2bb84ca4d337ff7fddaa7f2194c667ca59202025e7d06fa2091b89a3c4e0616c33c9d8ac067c1bfdc010f28871a248eb39')
package() {
- npm install -g --user root --prefix "${pkgdir}/usr" "$srcdir/${pkgname}-${_npmver}.tgz"
+ npm install -g --prefix "$pkgdir/usr" "$srcdir/$_pkgname-$pkgver.tgz"
- # Non-deterministic race in npm gives 777 permissions to random directories.
- # See https://github.com/npm/npm/issues/9359 for details.
- find "${pkgdir}/usr" -type d -exec chmod 755 {} +
-
- # npm gives ownership of ALL FILES to build user
- # https://bugs.archlinux.org/task/63396
- chown -R root:root "${pkgdir}"
+ install -Dm644 "$pkgdir/usr/lib/node_modules/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: