summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmilien Devos2020-01-27 10:33:24 +0100
committerEmilien Devos2020-01-27 10:35:45 +0100
commitcb6e125976b8d39f537d37531c9324468fa67795 (patch)
tree9cf301ca97f20a918622da191ab8d02f54a56d18
downloadaur-cb6e125976b8d39f537d37531c9324468fa67795.tar.gz
v13.7.0
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD60
-rw-r--r--patch.diff21
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a227986a146
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = nodejs-ipv6
+ pkgdesc = Evented I/O for V8 javascript
+ pkgver = 13.7.0
+ pkgrel = 1
+ url = https://nodejs.org/
+ arch = x86_64
+ license = MIT
+ makedepends = python
+ makedepends = procps-ng
+ depends = openssl
+ depends = zlib
+ depends = icu
+ depends = libuv
+ depends = c-ares
+ depends = libnghttp2
+ optdepends = npm: nodejs package manager
+ provides = nodejs
+ conflicts = nodejs
+ source = nodejs-13.7.0.tar.gz::https://github.com/nodejs/node/archive/v13.7.0.tar.gz
+ sha512sums = 1f4bec96b207a6650e3a031d9f37d75aa14b10e5540d33421145e770933052927def99c216fc8e12d849afa1bb4966e186c7ddc012e95b50aaaafc854aca85ce
+
+pkgname = nodejs-ipv6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ebc47dd3bef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: James Campos <james.r.campos@gmail.com>
+# Contributor: BlackEagle < ike DOT devolder AT gmail DOT com >
+# Contributor: Dongsheng Cai <dongsheng at moodle dot com>
+# Contributor: Masutu Subric <masutu.arch at googlemail dot com>
+# Contributor: TIanyi Cui <tianyicui@gmail.com>
+
+pkgname=nodejs-ipv6
+pkgver=13.7.0
+pkgrel=1
+pkgdesc='Evented I/O for V8 javascript'
+arch=('x86_64')
+provides=("${pkgname%-ipv6}")
+conflicts=("${pkgname%-ipv6}")
+url='https://nodejs.org/'
+license=('MIT')
+depends=('openssl' 'zlib' 'icu' 'libuv' 'c-ares' 'libnghttp2') # 'http-parser' 'v8')
+makedepends=('python' 'procps-ng')
+optdepends=('npm: nodejs package manager')
+source=("nodejs-$pkgver.tar.gz::https://github.com/nodejs/node/archive/v$pkgver.tar.gz")
+sha512sums=('1f4bec96b207a6650e3a031d9f37d75aa14b10e5540d33421145e770933052927def99c216fc8e12d849afa1bb4966e186c7ddc012e95b50aaaafc854aca85ce')
+
+build() {
+ cd node-$pkgver
+ patch lib/dns.js < ../../patch.diff
+
+ ./configure \
+ --prefix=/usr \
+ --with-intl=system-icu \
+ --without-npm \
+ --shared-openssl \
+ --shared-zlib \
+ --shared-libuv \
+ --experimental-http-parser \
+ --shared-cares \
+ --shared-nghttp2
+ # --shared-v8
+ # --shared-http-parser
+
+ make -j15
+}
+
+check() {
+ cd node-$pkgver
+ # Expected failure: https://github.com/nodejs/node/issues/11627
+ make test || warning "Tests failed"
+}
+
+package() {
+ cd node-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ install -D -m644 LICENSE \
+ "$pkgdir"/usr/share/licenses/nodejs/LICENSE
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/patch.diff b/patch.diff
new file mode 100644
index 000000000000..f1f4c7421ca6
--- /dev/null
+++ b/patch.diff
@@ -0,0 +1,21 @@
+--- lib/dns.js.bak 2020-01-26 19:09:18.114911160 +0100
++++ lib/dns.js 2020-01-26 20:31:28.720237093 +0100
+@@ -95,7 +95,7 @@
+ let hints = 0;
+ let family = -1;
+ let all = false;
+- let verbatim = false;
++ let verbatim = true;
+
+ // Parse arguments
+ if (hostname && typeof hostname !== 'string') {
+@@ -109,7 +109,7 @@
+ hints = options.hints >>> 0;
+ family = options.family >>> 0;
+ all = options.all === true;
+- verbatim = options.verbatim === true;
++ verbatim = options.verbatim !== false;
+
+ validateHints(hints);
+ } else {
+