summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Reggiani Manzo2016-08-15 06:36:51 -0300
committerRafael Reggiani Manzo2016-08-15 06:36:51 -0300
commit38f028896e98b7a8a74a7b3f21383b79cdefc2a2 (patch)
treefc982bea229fa27b30c29dda102fc9b44ac3f6ff
downloadaur-nodejs-istanbul.tar.gz
Release the frst version at v0.4.4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..307bdb2b907f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Aug 15 09:36:32 UTC 2016
+pkgbase = nodejs-istanbul
+ pkgdesc = Yet another JS code coverage tool that computes statement, line, function and branch coverage with module loader hooks to transparently add coverage when running tests. Supports all JS coverage use cases including unit tests, server side functional tests
+ pkgver = 0.4.4
+ pkgrel = 1
+ url = https://github.com/gotwarlost/istanbul#readme
+ arch = any
+ depends = nodejs
+ depends = npm
+ noextract = istanbul-0.4.4.tgz
+ source = http://registry.npmjs.org/istanbul/-/istanbul-0.4.4.tgz
+ sha1sums = e8cf718dfedb713c8334ab9ffade35f1042d2a56
+
+pkgname = nodejs-istanbul
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9cad9e596127
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Rafael Reggiani Manzo <rr.manzo#protonmail.com>
+
+_npmname=istanbul
+_npmver=0.4.4
+pkgname=nodejs-istanbul # All lowercase
+pkgver=0.4.4
+pkgrel=1
+pkgdesc="Yet another JS code coverage tool that computes statement, line, function and branch coverage with module loader hooks to transparently add coverage when running tests. Supports all JS coverage use cases including unit tests, server side functional tests "
+arch=(any)
+url="https://github.com/gotwarlost/istanbul#readme"
+license=()
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(e8cf718dfedb713c8334ab9ffade35f1042d2a56)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: