summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Noyce Barnham2020-01-22 19:37:10 +0000
committerJoel Noyce Barnham2020-01-22 19:37:10 +0000
commit429222fb2cc6b18e35b5ea98c7bec75ab7be11a7 (patch)
tree5d11f51aae7a1891cbca3fe1243e1bade71219f5
parentc097ac2bc52372bb2b5cd6222bdc7838ef0d7a7b (diff)
downloadaur-429222fb2cc6b18e35b5ea98c7bec75ab7be11a7.tar.gz
Shellcheck lints & removal of unneeded 'cd' commands
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf2c9f33cc3d..7466e394bad6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
_npmname=json-diff
-pkgname=nodejs-json-diff # All lowercase
+pkgname=nodejs-json-diff
pkgver=0.5.4
pkgrel=1
pkgdesc="JSON diff"
@@ -9,15 +9,13 @@ url="https://github.com/andreyvit/json-diff"
license=()
depends=('nodejs' 'npm')
optdepends=()
-source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
-noextract=($_npmname-$pkgver.tgz)
+source=("https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
+noextract=("$_npmname-$pkgver.tgz")
sha256sums=('81f7ce0aec1a8dbd8044753a0f786c25f1881a8c33068da0e05784ea083ff17a')
package() {
- cd $srcdir
local _npmdir="$pkgdir/usr/lib/node_modules/"
- mkdir -p $_npmdir
- cd $_npmdir
- npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+ mkdir -p "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" "$_npmname@$pkgver"
}
# vim:set ts=2 sw=2 et: