summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2021-06-19 17:26:07 +0000
committerGitHub Action2021-06-19 17:26:07 +0000
commit0a2a44e60ca16b5c30613c6203a266b3197eb163 (patch)
tree132d21eee9e26b7a71780654b7864949289fe60b
parent30078216f650c1b4353aa7dc876072c472c36501 (diff)
downloadaur-0a2a44e60ca16b5c30613c6203a266b3197eb163.tar.gz
Update from GitHub Actions: nodejs-mocha: update to 9.0.1-1
https://github.com/ouuan/AUR-packages/actions/runs/952851048
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 18 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a654156b1b8..f9ec7b4169f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = nodejs-mocha
- pkgdesc = Simple, flexible, fun test framework.
- pkgver = 7.1.2
+ pkgdesc = Simple, flexible, fun JavaScript test framework for Node.js & The Browser
+ pkgver = 9.0.1
pkgrel = 1
url = https://mochajs.org
arch = any
license = MIT
makedepends = npm
depends = nodejs
- noextract = mocha-7.1.2.tgz
- source = https://registry.npmjs.org/mocha/-/mocha-7.1.2.tgz
- sha256sums = fb780a77a7189f9ce732c7032dc7ff101ca20940b7fa34bb1091d01cfd79ce89
+ noextract = mocha-9.0.1.tgz
+ source = https://registry.npmjs.org/mocha/-/mocha-9.0.1.tgz
+ sha256sums = a28e7f2f2e98c54b4ac567f800e98d29075e803072d312840a29e21335193572
pkgname = nodejs-mocha
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index f71c635dafda..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!.gitignore
-!PKGBUILD
-!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 2ed553b33b3e..9f8c0286975d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
-# Maintainer: Mario Finelli <mario at finel dot li>
+# Maintainer: Yufan You <ouuansteve at gmail>
+# Contributor: Mario Finelli <mario at finel dot li>
# Contributor: Daniel Nagy <danielnagy at gmx de>
# Contributor: TJ Holowaychuk <tj at vision-media dot ca>
# Contributor: Travis Jeffery <tj at travisjeffery dot com>
_npmname=mocha
-pkgname=nodejs-$_npmname
-pkgver=7.1.2
+pkgname=nodejs-mocha
+pkgver=9.0.1
pkgrel=1
-pkgdesc="Simple, flexible, fun test framework."
+pkgdesc="Simple, flexible, fun JavaScript test framework for Node.js & The Browser"
arch=(any)
url="https://mochajs.org"
license=('MIT')
@@ -15,16 +16,14 @@ depends=('nodejs')
makedepends=('npm')
source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
noextract=($_npmname-$pkgver.tgz)
-sha256sums=('fb780a77a7189f9ce732c7032dc7ff101ca20940b7fa34bb1091d01cfd79ce89')
+sha256sums=('a28e7f2f2e98c54b4ac567f800e98d29075e803072d312840a29e21335193572')
package() {
- npm install \
- --user root --global \
- --prefix "$pkgdir/usr" \
- "$srcdir"/$_npmname-$pkgver.tgz
-
- find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
-
- install -Dm0644 "$pkgdir/usr/lib/node_modules/$_npmname/LICENSE" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" "$_npmname@$pkgver"
+ install -Dm644 "$_npmdir/$_npmname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ chown -R root:root "${pkgdir}"
}