summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiel Fridman2019-04-07 10:08:18 +0300
committerLiel Fridman2019-04-07 10:08:18 +0300
commite3e7fd26797d0cca83739251ce4cedb26b80a5d2 (patch)
treefbea0313710d45ac5fd7229199a1fe50b96ea73a
parentbb7acaa7ec514c1f0fe90bef27786610ac4e65ee (diff)
downloadaur-nodejs-nearley.tar.gz
Updating to 2.16.0 and improving the package sanity.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64199ce134c2..dd11bc657cd7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = nodejs-nearley
pkgdesc = nearley is a simple, fast and powerful parsing toolkit.
- pkgver = 2.15.1
+ pkgver = 2.16.0
pkgrel = 0
url = https://www.npmjs.com/package/nearley
arch = any
license = MIT
+ makedepends = npm
depends = nodejs
- depends = npm
- noextract = nearley-2.15.1.tgz
- source = http://registry.npmjs.org/nearley/-/nearley-2.15.1.tgz
- md5sums = 68417ae8f248b046fc6cc8c9b188bd73
+ noextract = nearley-2.16.0.tgz
+ source = http://registry.npmjs.org/nearley/-/nearley-2.16.0.tgz
+ md5sums = 7c4ab45ac94eff69b00ce2ed58c9fbfb
pkgname = nodejs-nearley
diff --git a/PKGBUILD b/PKGBUILD
index 4e7dc6354599..21e41aa59ba9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,27 @@
_npmname=nearley
pkgname=nodejs-nearley
-pkgver=2.15.1
+pkgver=2.16.0
pkgrel=0
pkgdesc="nearley is a simple, fast and powerful parsing toolkit."
arch=(any)
url="https://www.npmjs.com/package/nearley"
license=( "MIT" )
-depends=('nodejs' 'npm' )
+depends=('nodejs')
+makedepends=( 'npm' )
optdepends=()
source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
noextract=($_npmname-$pkgver.tgz)
-md5sums=('68417ae8f248b046fc6cc8c9b188bd73')
+md5sums=('7c4ab45ac94eff69b00ce2ed58c9fbfb')
package() {
cd "$srcdir"
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p "$_npmdir"
cd "$_npmdir"
- npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+ npm install -g --prefix "$pkgdir/usr" "$srcdir/$_npmname-$pkgver.tgz"
+ install -Dm644 "$pkgdir/usr/lib/node_modules/$_npmname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ find "$pkgdir" -exec chmod 755 {} \;
+ find "$pkgdir" -exec chown root:root {} \;
+
}