summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Pizarro Callejas2022-05-09 18:10:20 -0400
committerJorge Pizarro Callejas2022-05-09 18:10:20 -0400
commit657ee4217f9ce74c03b4d0fca65f1be8829cb8a1 (patch)
tree42aada1955a1aa79b82baa79398696a2d74f0ce8
downloadaur-657ee4217f9ce74c03b4d0fca65f1be8829cb8a1.tar.gz
New package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..384ad0cf7375
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nodejs-ngrok
+ pkgdesc = Node.js module and implementation of ngrok
+ pkgver = 4.3.1
+ pkgrel = 1
+ url = https://github.com/bubenshchykov/ngrok
+ arch = any
+ license = BSD-2-Clause
+ makedepends = npm
+ depends = nodejs
+ provides = ngrok
+ conflicts = ngrok
+ noextract = ngrok-4.3.1.tgz
+ source = http://registry.npmjs.org/ngrok/-/ngrok-4.3.1.tgz
+ sha256sums = a76c5fc9d623ed3718817b9549de1a5a0d140ae449961e75019964f1850634a9
+
+pkgname = nodejs-ngrok
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fd7beedf705
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jorge Pizarro-Callejas <jpizarrocallejas@gmail.com>
+
+pkgname=nodejs-ngrok
+_pkgname=ngrok
+pkgver=4.3.1
+pkgrel=1
+pkgdesc="Node.js module and implementation of ngrok"
+arch=(any)
+url="https://github.com/bubenshchykov/ngrok"
+license=('BSD-2-Clause')
+depends=('nodejs')
+makedepends=('npm')
+provides=('ngrok')
+conflicts=('ngrok')
+source=("http://registry.npmjs.org/${_pkgname}/-/${_pkgname}-${pkgver}.tgz")
+noextract=(${_pkgname}-${pkgver}.tgz)
+sha256sums=('a76c5fc9d623ed3718817b9549de1a5a0d140ae449961e75019964f1850634a9')
+
+package() {
+ npm install -g --user root --prefix "$pkgdir/usr" "$srcdir"/${_pkgname}-${pkgver}.tgz
+
+ find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
+}