summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Schleifenbaum2014-12-30 10:50:45 +0100
committerJohannes Schleifenbaum2014-12-30 10:50:45 +0100
commitbe2a90cc5309d2cd34731f403113d0057f563c3c (patch)
treeb30215e18980f6596c726cb170cc7e29e1252884
downloadaur-be2a90cc5309d2cd34731f403113d0057f563c3c.tar.gz
all packages in aur subfolder
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD36
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf22f34ec633
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nodejs-pageres
+ pkgdesc = Get screenshots of websites in different resolutions
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/sindresorhus/pageres
+ arch = any
+ license = MIT
+ depends = nodejs
+ noextract = pageres-1.1.0.tgz
+ source = http://registry.npmjs.org/pageres/-/pageres-1.1.0.tgz
+ source = LICENSE
+ sha1sums = 11fa89444d377941971d092d756f40c12337fc79
+ sha1sums = 855b17174b0193c9fbcaf000327b2bcb3d4c38fd
+ sha256sums = ffe735a8679180e90f23d204afda686930ae40af7263e8cb2b926a13624ec10c
+ sha256sums = a09bad52fe9deab4338f4f80105f8b8d0c10a2618a8b4517a2cf260b48d968d2
+
+pkgname = nodejs-pageres
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f35e7e2be316
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.pkg.*
+pkg/
+src/
+*.tgz
+*.pkg.*.sig
+*.src.tar.gz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8e8fede5b9df
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) Sindre Sorhus
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..528aac844633
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Johannes Schleifenbaum <johannes [at] js-webcoding [dot] de>
+# Please report issues at https://github.com/jojosch/pkgbuilds
+
+pkgname=nodejs-pageres
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Get screenshots of websites in different resolutions"
+arch=(any)
+url="https://github.com/sindresorhus/pageres"
+license=("MIT")
+depends=('nodejs')
+optdepends=()
+source=(
+ "http://registry.npmjs.org/${pkgname/nodejs-/}/-/${pkgname/nodejs-/}-${pkgver}.tgz"
+ "LICENSE"
+)
+noextract=("${pkgname/nodejs-/}-${pkgver}.tgz")
+sha1sums=(
+ '11fa89444d377941971d092d756f40c12337fc79'
+ '855b17174b0193c9fbcaf000327b2bcb3d4c38fd'
+)
+sha256sums=(
+ 'ffe735a8679180e90f23d204afda686930ae40af7263e8cb2b926a13624ec10c'
+ 'a09bad52fe9deab4338f4f80105f8b8d0c10a2618a8b4517a2cf260b48d968d2'
+)
+
+package() {
+ cd "${srcdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ local _npmdir="${pkgdir}/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+
+ npm install --user root -g --prefix "${pkgdir}/usr" "${pkgname/nodejs-/}@${pkgver}"
+}