summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-12 13:36:48 +0300
committerCaleb Maclennan2020-02-12 13:36:48 +0300
commit6e752a2e1e7b2b5148681ac97560bccebea20a9b (patch)
tree7d720771ba50ad65e4585e19e80f973d57e5744e
parentaf0c417a63b24081e86991d79bf61513e46ad845 (diff)
downloadaur-6e752a2e1e7b2b5148681ac97560bccebea20a9b.tar.gz
Cleanup bash shell quoting using shellharden
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 466e8df358a5..866c503b35a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,10 +15,10 @@ noextract=("${source[@]##*/}")
sha256sums=('2ca38a951203aabdea1b198289e531562c7ee5ca00eda9e42012a4bf10a4978c')
package() {
- npm install -g --user root --cache "${srcdir}/npm-cache" --prefix "$pkgdir/usr" "${source[@]##*/}"
- find "${pkgdir}"/usr -type d -exec chmod 755 {} +
- find "${pkgdir}" -type f -name package.json -exec sed -i -e "/${pkgdir//\//\\/}/d" -e "/${srcdir//\//\\/}/d" {} \;
- chown -R root:root $pkgdir
+ npm install -g --user root --cache "$srcdir/npm-cache" --prefix "$pkgdir/usr" "${source[@]##*/}"
+ find "$pkgdir"/usr -type d -exec chmod 755 {} +
+ find "$pkgdir" -type f -name package.json -exec sed -i -e "/${pkgdir//\//\\/}/d" -e "/${srcdir//\//\\/}/d" {} \;
+ chown -R root:root "$pkgdir"
}
# vim:set ts=2 sw=2 et: