summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatoro2017-09-14 21:02:44 -0500
committermatoro2017-09-14 21:02:44 -0500
commit948fceb52e9bd503a8df4caaff471c7234f637b6 (patch)
tree5656163789f65712d9681d150a1851b2036efc6f
downloadaur-948fceb52e9bd503a8df4caaff471c7234f637b6.tar.gz
Initial commit: v0.4.19
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7c838cae682
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nodejs-resume-cli
+ pkgdesc = This is the command line tool for JSON Resume, the open source initiative to create a JSON-based standard for resumes.
+ pkgver = 0.4.19
+ pkgrel = 1
+ url = https://github.com/jsonresume/resume-cli
+ arch = any
+ license = MIT
+ depends = nodejs
+ depends = npm
+ noextract = resume-cli-0.4.19.tgz
+ source = https://registry.npmjs.org/resume-cli/-/resume-cli-0.4.19.tgz
+ sha256sums = 5394cb51e00128c3cb0329125ae429edab3d2367c7f3b6e00919134730467623
+
+pkgname = nodejs-resume-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34e74b041e51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+_npmname=resume-cli
+_npmver=0.4.19
+pkgname=nodejs-resume-cli
+pkgver=${_npmver}
+pkgrel=1
+pkgdesc="This is the command line tool for JSON Resume, the open source initiative to create a JSON-based standard for resumes."
+arch=(any)
+url="https://github.com/jsonresume/resume-cli"
+license=('MIT')
+depends=('nodejs' 'npm')
+source=("https://registry.npmjs.org/${_npmname}/-/${_npmname}-${_npmver}.tgz")
+noextract=(${_npmname}-${_npmver}.tgz)
+sha256sums=(5394cb51e00128c3cb0329125ae429edab3d2367c7f3b6e00919134730467623)
+
+package() {
+ cd ${srcdir}
+ local _npmdir="${pkgdir}/usr/lib/node_modules/"
+ mkdir -p ${_npmdir}
+ cd ${_npmdir}
+ npm install -g --prefix "${pkgdir}/usr" ${_npmname}@${_npmver}
+}
+
+# vim:set ts=2 sw=2 et: