summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKimiblock Moe2024-01-12 14:04:17 +0800
committerKimiblock Moe2024-01-12 14:04:17 +0800
commitb7eb42658f8d3bbcc5140038e34c169acb5299b8 (patch)
tree21d1b29dc1fcacee611bdcddc8bf2fea4d69a32f
downloadaur-b7eb42658f8d3bbcc5140038e34c169acb5299b8.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..650685ed85b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = nodejs-reveal.js
+ pkgdesc = The HTML Presentation Framework
+ pkgver = 5.0.4
+ pkgrel = 1
+ url = https://github.com/hakimel/reveal.js
+ arch = any
+ license = MIT
+ makedepends = npm
+ noextract = reveal.js-.tgz
+ source = reveal.js-5.0.4.tgz::https://registry.npmjs.org/reveal.js/-/reveal.js-5.0.4.tgz
+ sha256sums = 95cd9acaa32361a32084fd444c5707e7aa43bfb6b3fab18ff9a2f399072b1d4c
+
+pkgname = nodejs-reveal.js
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e5b12f1c46e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Kimiblock Moe
+
+pkgname=nodejs-reveal.js
+_pkgname=${pkgname#nodejs-}
+pkgdesc="The HTML Presentation Framework"
+url="https://github.com/hakimel/reveal.js"
+license=(MIT)
+makedepends=('npm')
+noextract=("${_pkgname}-${pkgver}.tgz")
+sha256sums=('95cd9acaa32361a32084fd444c5707e7aa43bfb6b3fab18ff9a2f399072b1d4c')
+arch=(any)
+pkgver=5.0.4
+pkgrel=1
+source=(
+ "${_pkgname}-${pkgver}.tgz"::"https://registry.npmjs.org/${_pkgname}/-/${_pkgname}-${pkgver}.tgz"
+)
+function package() {
+ npm install -g --prefix "${pkgdir}/usr" "${srcdir}/${_pkgname}-${pkgver}.tgz"
+ find "${pkgdir}" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+}