summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbacteriostat2022-05-06 22:16:37 +0530
committerbacteriostat2022-05-06 22:16:37 +0530
commit097110ab176537ef6c296a29d4365fde27df91bd (patch)
tree3b91787aef7a8cb6139bbe1a2cb3fd96cb70b4c4
parentdae98fc21d8a41810d1e4b960b6643df7cc2ed3b (diff)
downloadaur-097110ab176537ef6c296a29d4365fde27df91bd.tar.gz
Uncomment permission fix as users maybe still using older npm versions via nvm
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c864c1cd35cf..b1a377117f5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: bacteriostat <dev.bacteriostat at aleeas dot com>
# Contributor: Hugues Chabot <at google mail>
_npmname=serverless
-pkgname=nodejs-$_npmname # All lowercase
+pkgname=nodejs-$_npmname
pkgver=3.16.0
pkgrel=2
pkgdesc="Serverless Framework - Build web, mobile and IoT applications with serverless architectures using AWS Lambda, Azure Functions, Google CloudFunctions & more"
@@ -24,7 +24,7 @@ package() {
# Non-deterministic race in npm gives 777 permissions to random directories.
# See https://github.com/npm/npm/issues/9359 for details.
- # find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+ find "${pkgdir}"/usr -type d -exec chmod 755 {} +
# npm gives ownership of ALL FILES to build user
# https://bugs.archlinux.org/task/63396