summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2017-02-13 11:54:24 +0200
committerChristoph Gysin2017-02-13 11:54:24 +0200
commit15ffe16884444c3bd11197151fde8417d4b2032f (patch)
tree903aa81cf753cce20850415a0dd943a105918359
downloadaur-15ffe16884444c3bd11197151fde8417d4b2032f.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78f8883390f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Feb 13 09:54:09 UTC 2017
+pkgbase = nodejs-serverless-git
+ pkgdesc = Serverless Framework - Build web, mobile and IoT applications with serverless architectures using AWS Lambda, Azure Functions, Google CloudFunctions & more
+ pkgver = v1.6.1.36.g88c9dc88
+ pkgrel = 1
+ url = https://serverless.com
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ provides = nodejs-serverless
+ conflicts = nodejs-serverless
+ source = git+https://github.com/serverless/serverless
+ sha256sums = SKIP
+
+pkgname = nodejs-serverless-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9ea98997cab5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar.*
+/pkg/
+/src/
+/serverless/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..531f9c14d650
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
+
+pkgname=nodejs-serverless-git
+_pkgname=serverless
+pkgver=v1.6.1.36.g88c9dc88
+pkgrel=1
+pkgdesc="Serverless Framework - Build web, mobile and IoT applications with serverless architectures using AWS Lambda, Azure Functions, Google CloudFunctions & more"
+arch=('any')
+url="https://serverless.com"
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+provides=(nodejs-serverless)
+conflicts=(nodejs-serverless)
+source=("git+https://github.com/${_pkgname}/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ local ver="$(git describe --tags)"
+ printf "%s" "${ver//-/.}"
+}
+
+package() {
+ npm \
+ install \
+ --user root \
+ --global \
+ --prefix "${pkgdir}/usr" \
+ --cache "${srcdir}/npm-cache" \
+ "${srcdir}/${_pkgname}"
+}
+
+# vim:set ts=2 sw=2 et: