summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2021-06-20 01:49:35 +0000
committerGitHub Action2021-06-20 01:49:35 +0000
commita9e971c6b89191ca76b11fafe955feb40601ac43 (patch)
tree9bc20617df4098a44be4e4ab44d80dd0db01bd39
parent926494c830d16e13840b8ec821829621bcd1a0f0 (diff)
downloadaur-a9e971c6b89191ca76b11fafe955feb40601ac43.tar.gz
Update from GitHub Actions: nodejs-ts-node: update to 10.0.0-1
https://github.com/ouuan/AUR-packages/actions/runs/953547992
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
3 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ff286203fbe..534556c90b9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = nodejs-ts-node
- pkgdesc = TypeScript execution environment and REPL for node
- pkgver = 5.0.0
+ pkgdesc = TypeScript execution and REPL for node.js
+ pkgver = 10.0.0
pkgrel = 1
url = https://github.com/TypeStrong/ts-node
arch = any
license = MIT
makedepends = npm
depends = nodejs
- options = !emptydirs
+ noextract = ts-node-10.0.0.tgz
+ source = https://registry.npmjs.org/ts-node/-/ts-node-10.0.0.tgz
+ sha256sums = 43b5ebb7a1d20d0802ef954675a855a3797a4b5c2e0d632456ae0993eabfb639
pkgname = nodejs-ts-node
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index e1b6a078e374..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,3 +0,0 @@
-/nodejs-ts-node-*-any.pkg.tar.xz
-/pkg/
-/src/
diff --git a/PKGBUILD b/PKGBUILD
index 39c735172c2b..5b0452549a3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
+# Maintainer: Yufan You <ouuansteve at gmail>
# Contributor: Nicola Squartini <tensor5@gmail.com>
-# Maintainer: Jian Zeng <anonymousknight96+aur AT gmail.com>
+# Contributor: Jian Zeng <anonymousknight96+aur AT gmail.com>
+_npmname=ts-node
pkgname=nodejs-ts-node
-pkgver=5.0.0
+pkgver=10.0.0
pkgrel=1
-pkgdesc='TypeScript execution environment and REPL for node'
+pkgdesc='TypeScript execution and REPL for node.js'
arch=('any')
url='https://github.com/TypeStrong/ts-node'
license=('MIT')
depends=('nodejs')
makedepends=('npm')
-options=(!emptydirs)
+source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+sha256sums=('43b5ebb7a1d20d0802ef954675a855a3797a4b5c2e0d632456ae0993eabfb639')
package() {
- npm install --user root -g --prefix="${pkgdir}"/usr ts-node@${pkgver}
-
- install -d "${pkgdir}/usr/share/licenses/${pkgname}"
- ln -s ../../../lib/node_modules/ts-node/LICENSE \
- "${pkgdir}/usr/share/licenses/${pkgname}"
-
- find "${pkgdir}" -name "package.json" -exec sed -e "s|${pkgdir}||" -i {} \;
- sed -e "s|${srcdir}|/|" \
- -i "${pkgdir}"/usr/lib/node_modules/ts-node/package.json
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" "$_npmname@$pkgver"
+ install -Dm644 "$_npmdir/$_npmname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ chown -R root:root "${pkgdir}"
}