summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2017-11-20 16:32:06 +0100
committerMarco Pompili2017-11-20 16:32:06 +0100
commita14faf8dd3a122df6ffe9449ff8b5208b48c47dc (patch)
tree4eed9b9866541835e38a128a618f5461f9523178
parente329a1e5de236a97860d6f9297848d812689dd3e (diff)
downloadaur-a14faf8dd3a122df6ffe9449ff8b5208b48c47dc.tar.gz
Version 1.2.3-1
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 371eb1c53b80..12696b3c4b72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Sep 20 11:54:10 UTC 2017
+# Mon Nov 20 14:59:43 UTC 2017
pkgbase = nodejs-ungit
pkgdesc = Git made easy
- pkgver = 1.1.29
+ pkgver = 1.2.3
pkgrel = 1
url = https://www.npmjs.com/package/ungit
arch = i686
@@ -15,8 +15,8 @@ pkgbase = nodejs-ungit
conflicts = ungit
options = !emptydirs
options = !strip
- source = nodejs-ungit-1.1.29.tgz::https://registry.npmjs.org/ungit/-/ungit-1.1.29.tgz
- sha256sums = fa15cdb478b5451dc537e315228cb2f8a5b284ad30c80384a01bca78cd3a2929
+ source = nodejs-ungit-1.2.3.tgz::https://registry.npmjs.org/ungit/-/ungit-1.2.3.tgz
+ sha256sums = 69c997bc14ee106f7ca15e41c551442596552bf846b742a66a8d23cd9ea80dba
pkgname = nodejs-ungit
diff --git a/.gitignore b/.gitignore
index 241dc51b047d..f9b93e4765db 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
src/
pkg/
+*.tgz
*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index d0dabe219175..259831401e26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
_npmname=ungit
-_npmver=1.1.29
+_npmver=1.2.3
pkgname=nodejs-ungit
-pkgver=1.1.29
+pkgver=1.2.3
pkgrel=1
pkgdesc="Git made easy"
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ provides=('nodejs-ungit' 'ungit')
conflicts=('ungit')
options=('!emptydirs' '!strip')
source=("${pkgname}-${pkgver}.tgz::https://registry.npmjs.org/ungit/-/ungit-${pkgver}.tgz")
-sha256sums=('fa15cdb478b5451dc537e315228cb2f8a5b284ad30c80384a01bca78cd3a2929')
+sha256sums=('69c997bc14ee106f7ca15e41c551442596552bf846b742a66a8d23cd9ea80dba')
package() {
cd ${srcdir}
@@ -27,4 +27,8 @@ package() {
msg2 'Renaming binary from 0ungit-credentials-helper to ungit-credentials-helper'
mv "${pkgdir}/usr/bin/0ungit-credentials-helper" "${pkgdir}/usr/bin/ungit-credentials-helper"
+
+ # fixing perms
+ chmod 755 ${pkgdir}/usr/bin/
+ chmod -R 755 ${pkgdir}/usr/lib/node_modules/
}