summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commitdbeeccbb00e27d66ae32a15423654f7f0a16ffdc (patch)
tree9b8ab66e8d8a58adae2a27ecae234128fa587a65
downloadaur-dbeeccbb00e27d66ae32a15423654f7f0a16ffdc.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73034bcd7f7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nodejs-ungit
+ pkgdesc = Git made easy
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://github.com/FredrikNoren/ungit
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ provides = nodejs-ungit
+ provides = ungit
+ conflicts = ungit
+ options = !emptydirs
+ options = !strip
+
+pkgname = nodejs-ungit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5668825fb9e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=nodejs-ungit
+_npmname=ungit
+pkgver=0.9.2
+pkgrel=1
+pkgdesc="Git made easy"
+arch=('i686' 'x86_64')
+depends=('nodejs')
+makedepends=('npm')
+url="https://github.com/FredrikNoren/ungit"
+license=('MIT')
+provides=('nodejs-ungit' 'ungit')
+conflicts=('ungit')
+options=('!emptydirs' '!strip')
+
+package() {
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+
+ msg 'Renaming binary from 0ungit-credentials-helper to ungit-credentials-helper'
+ mv "$pkgdir/usr/bin/0ungit-credentials-helper" "$pkgdir/usr/bin/ungit-credentials-helper"
+}