summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2017-01-31 10:23:13 +0200
committerChristoph Gysin2017-01-31 10:25:31 +0200
commit2bce40bac5de831e585ad6fca5d2490df8d88220 (patch)
tree77a0da76e30a1519f5b0ded2a64dba15bad7a801
downloadaur-2bce40bac5de831e585ad6fca5d2490df8d88220.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b22d8a980300
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Jan 31 08:20:30 UTC 2017
+pkgbase = nodejs-webtorrent-cli
+ pkgdesc = WebTorrent, the streaming torrent client. For the command line.
+ pkgver = 1.9.0
+ pkgrel = 1
+ url = https://webtorrent.io
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ source = https://github.com/feross/webtorrent-cli/archive/v1.9.0.tar.gz
+ sha256sums = 5e5238267e2119484e9910b500bd46f9ebf5ae0a38f37f5044a64041bef0ac53
+
+pkgname = nodejs-webtorrent-cli
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d725ba4cf0d2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37d8b0ce2a73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
+
+pkgname=nodejs-webtorrent-cli
+_pkgname="${pkgname#nodejs-}"
+pkgver=1.9.0
+pkgrel=1
+pkgdesc='WebTorrent, the streaming torrent client. For the command line.'
+arch=('i686' 'x86_64')
+url='https://webtorrent.io'
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+source=("https://github.com/feross/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('5e5238267e2119484e9910b500bd46f9ebf5ae0a38f37f5044a64041bef0ac53')
+
+package() {
+ npm \
+ install \
+ --user root \
+ --global \
+ --prefix "${pkgdir}/usr" \
+ --cache "${srcdir}/npm-cache" \
+ "${srcdir}/${_pkgname}-${pkgver}"
+}
+
+# vim:set ts=2 sw=2 et: