summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 19:47:39 +0200
committerDaniel Nagy2015-06-08 19:47:39 +0200
commit20f845bb0a12c9f2744ebd85433cbd67e49ab6ae (patch)
treea736fd7600ca6c1c8a0305842c61c9989da8aa73
downloadaur-20f845bb0a12c9f2744ebd85433cbd67e49ab6ae.tar.gz
import to aur4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2aff9910dd57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nodejs-ws
+ pkgdesc = simple to use, blazing fast and thoroughly tested websocket client, server and console for node.js, up-to-date against RFC-6455
+ pkgver = 0.4.30
+ pkgrel = 1
+ url = http://github.com/einaros/ws
+ arch = any
+ license = MIT
+ depends = nodejs
+ noextract = ws-0.4.30.tgz
+ source = http://registry.npmjs.org/ws/-/ws-0.4.30.tgz
+ sha1sums = 5e2c18b7bb7ee0f9c9fcc3d3ec50f513ba5f99e8
+
+pkgname = nodejs-ws
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab1473054dca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Einar Otto Stangvik <einaros@gmail.com> (http://2x.io)
+# Contributor: einaros <einaros@gmail.com>
+# Contributor: V1 <info@3rd-Eden.com>
+
+_npmname=ws
+_npmver=0.4.30
+pkgname=nodejs-ws # All lowercase
+pkgver=0.4.30
+pkgrel=1
+pkgdesc="simple to use, blazing fast and thoroughly tested websocket client, server and console for node.js, up-to-date against RFC-6455"
+arch=(any)
+url="http://github.com/einaros/ws"
+license=( "MIT" )
+depends=('nodejs' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=('5e2c18b7bb7ee0f9c9fcc3d3ec50f513ba5f99e8')
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: