summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Vinícios de Souza2023-10-28 16:13:08 -0300
committerGustavo Vinícios de Souza2023-10-28 16:13:08 -0300
commitf4be303f67f67059b2a37f8693355b68ea2f4761 (patch)
tree1d69c42d25f64dccdf05772ebd8d484eed5501db
downloadaur-f4be303f67f67059b2a37f8693355b68ea2f4761.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3676a624a840
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nodejs-xdccjs
+ pkgdesc = download files from XDCC bots on IRC, complete implementation of the XDCC protocol
+ pkgver = 5.1.5
+ pkgrel = 1
+ url = https://github.com/JiPaix/xdccJS
+ arch = any
+ license = MIT
+ depends = nodejs
+ depends = npm
+ noextract = xdccjs-5.1.5.tgz
+ source = https://registry.npmjs.org/xdccjs/-/xdccjs-5.1.5.tgz
+ sha1sums = 246798e14c0cba4f85a8c78ca395503638acd753
+
+pkgname = nodejs-xdccjs
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b39f3b2a183f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.gitignore
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..952b903bb842
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Gustavo Vinícios de Souza <gnsfujiwara@disroot.org>
+
+_npmname=xdccjs
+_npmver=5.1.5
+pkgname=nodejs-xdccjs
+pkgver=5.1.5
+pkgrel=1
+pkgdesc="download files from XDCC bots on IRC, complete implementation of the XDCC protocol"
+arch=('any')
+url="https://github.com/JiPaix/xdccJS"
+license=('MIT')
+depends=('nodejs' 'npm')
+source=("https://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz")
+noextract=("$_npmname-$_npmver.tgz")
+sha1sums=('246798e14c0cba4f85a8c78ca395503638acd753')
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" "$_npmname@$_npmver"
+ chown -R root:root "$pkgdir"
+}