summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMárk Sági-Kazár2016-01-21 18:08:28 +0100
committerMárk Sági-Kazár2016-01-21 18:08:28 +0100
commit7006673fe2a186ee1d8743f0558814ebebc52e89 (patch)
tree28665645b7f04b189d51b3a86eda9dfa02219cd7
downloadaur-7006673fe2a186ee1d8743f0558814ebebc52e89.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
-rw-r--r--nodenv.install10
4 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27a15eaa19be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Jan 21 16:58:53 UTC 2016
+pkgbase = nodenv
+ pkgdesc = Manage multiple NodeJS versions
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/nodenv/nodenv
+ install = nodenv.install
+ arch = any
+ license = MIT
+ optdepends = nodenv-node-build
+ conflicts = nodenv-git
+ source = https://github.com/nodenv/nodenv/archive/v1.0.0.tar.gz
+ md5sums = 7750715a580d81ea9a8a63def8131b6b
+
+pkgname = nodenv
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3ffbbace5f02
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7dc48b3ff6f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Márk Sági-Kazár <mark.sagi-kazar@gmail.com>
+
+pkgname=nodenv
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Manage multiple NodeJS versions"
+arch=('any')
+url="https://github.com/nodenv/nodenv"
+license=('MIT')
+optdepends=('nodenv-node-build')
+conflicts=("${pkgname}-git")
+install=nodenv.install
+source=("${url}/archive/v${pkgver}.tar.gz")
+md5sums=("7750715a580d81ea9a8a63def8131b6b")
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/lib/${pkgname}/completions"
+ mkdir -p "${pkgdir}/usr/lib/${pkgname}/libexec"
+
+ install -m 644 ./completions/* "${pkgdir}/usr/lib/${pkgname}/completions/"
+ install -m 755 ./libexec/* "${pkgdir}/usr/lib/${pkgname}/libexec/"
+
+ ln -s "/usr/lib/${pkgname}/libexec/${pkgname}" "${pkgdir}/usr/bin/"
+}
diff --git a/nodenv.install b/nodenv.install
new file mode 100644
index 000000000000..bc353c243970
--- /dev/null
+++ b/nodenv.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo 'Your shell must be initialized before nodenv will function correctly.'
+ echo 'Run the following, and consider adding it to your shell rc:'
+ echo ' eval "$(nodenv init -)"'
+}
+
+post_remove() {
+ echo 'Remove the following from your shell rc, if present:'
+ echo ' eval "$(nodenv init -)"'
+}