summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorraf2023-08-30 21:39:33 +1000
committerraf2023-08-30 21:39:33 +1000
commitef10f180c948120561d1b1ea388ab18a647587f4 (patch)
tree72ef93127770737c0b02b2782eada0e9c7ed6ab3
downloadaur-ef10f180c948120561d1b1ea388ab18a647587f4.tar.gz
noexcuses-1.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd68284b572f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = noexcuses
+ pkgdesc = Runs important cronjobs until they succeed
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://raf.org/noexcuses/
+ arch = any
+ license = GPL
+ depends = perl>=5.6
+ depends = inetutils
+ source = https://github.com/raforg/noexcuses/releases/download/v1.0/noexcuses-1.0.tar.gz
+ sha256sums = cab7819d9a4aa76d9019cb86ee4d53cec257b22b8d59cfcbf3edace13ea2449f
+
+pkgname = noexcuses
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7087327496a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: raf <raf at raf dot org>
+pkgname=noexcuses
+pkgver=1.0
+pkgrel=1
+pkgdesc="Runs important cronjobs until they succeed"
+arch=("any")
+url=https://raf.org/noexcuses/
+license=("GPL")
+depends=("perl>=5.6" "inetutils")
+source=("https://github.com/raforg/noexcuses/releases/download/v1.0/noexcuses-1.0.tar.gz")
+sha256sums=("cab7819d9a4aa76d9019cb86ee4d53cec257b22b8d59cfcbf3edace13ea2449f")
+
+prepare()
+{
+ cd "$pkgname-$pkgver"
+ # Adapt -m test to troff warnings and tty escapes even when piped
+ perl -pi \
+ -e 's/noexcuses -m 2>[&]1/noexcuses -m 2>&-/;' \
+ -e "s/^.*NOEXCUSES.*$/'NOEXCUSES.+USER COMMANDS.+NOEXCUSES' \\\\/" \
+ run-tests
+}
+
+check()
+{
+ cd "$pkgname-$pkgver"
+ make test
+}
+
+package()
+{
+ cd "$pkgname-$pkgver"
+ make PREFIX="$pkgdir"/usr ETCDIR="$pkgdir"/etc VARDIR="$pkgdir/var" MANDIR="$pkgdir"/usr/share/man/man1 install
+}
+