summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShrinivas Vishnu Kumbhar2021-03-16 17:10:05 +0530
committerShrinivas Vishnu Kumbhar2021-03-16 17:10:05 +0530
commit7a2d93976e3defd1fb4ab125ac47b50ef6a83bd6 (patch)
treed0a902eeb31069d9a6e38bc557ec11c099d7ccde
downloadaur-7a2d93976e3defd1fb4ab125ac47b50ef6a83bd6.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78252788be42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nohang
+ pkgdesc = A sophisticated low memory handler.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/hakavlad/nohang
+ arch = any
+ license = MIT
+ depends = python
+ conflicts = nohang
+ backup = etc/nohang/nohang.conf
+ backup = etc/nohang/nohang-desktop.conf
+ backup = etc/logrotate.d/nohang
+ source = nohang::https://github.com/hakavlad/nohang/archive/v0.2.0.tar.gz
+ md5sums = SKIP
+
+pkgname = nohang
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..544027aa362a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Librewish <librewish AT gmail.com>
+
+_pkgname=nohang
+pkgname=${_pkgname}
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A sophisticated low memory handler."
+arch=('any')
+url="https://github.com/hakavlad/nohang"
+license=('MIT')
+source=(
+ "$pkgname::https://github.com/hakavlad/nohang/archive/v${pkgver}.tar.gz"
+)
+md5sums=('SKIP')
+depends=(
+ 'python'
+)
+
+conflicts=("${_pkgname}")
+backup=(
+ 'etc/nohang/nohang.conf'
+ 'etc/nohang/nohang-desktop.conf'
+ 'etc/logrotate.d/nohang'
+)
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
+ make \
+ DESTDIR="${pkgdir}" \
+ PREFIX="/usr" \
+ SBINDIR="/usr/bin" \
+ SYSCONFDIR="/etc" \
+ SYSTEMDUNITDIR="/usr/lib/systemd/system" \
+ install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}