summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2018-11-09 05:10:36 +0100
committeractionless2018-11-09 05:10:36 +0100
commit9a3604a52008e559d3c5995f2fd9a9d53cfcfa9d (patch)
tree5cd397000332ba1fc5db868fdd3cb26730a045d1
parente26ac295b0cbeb458d04c1023bd28ab99bb0bd5b (diff)
downloadaur-9a3604a52008e559d3c5995f2fd9a9d53cfcfa9d.tar.gz
simplify fallback version generation
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 346babe250db..c4a120e762fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ pkgver() {
cd "${srcdir}/${pkgname}" || exit 2
set -o pipefail
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' || \
- echo "r$(git log --oneline | wc -l).$(git describe --always | sed 's/^/g/')"
+ echo "r$(git log --oneline | wc -l).g$(git describe --always)"
}
package() {