summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Frankenau2016-03-02 22:35:44 +0100
committerJohannes Frankenau2016-03-02 22:35:44 +0100
commit65f26bf234233473f7146c84cafebce1dcfee952 (patch)
tree7104f2e98e2eae7bbb6a93c6ce3654a7907e84fe
parent8d6f864f614468ae6f37c2896868ae9279444943 (diff)
downloadaur-65f26bf234233473f7146c84cafebce1dcfee952.tar.gz
Update configuration file for 0.4
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--config.h15
3 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d906b940d56..e418422c0106 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Mar 2 21:35:24 UTC 2016
pkgbase = noice-git
pkgdesc = Small file browser
- pkgver = 0.2.r17.g62736bf
+ pkgver = 0.4.r18.g829bcdd
pkgrel = 1
url = http://git.2f30.org/noice/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 2baa914d5fa7..338a106aff4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=noice-git
_pkgname=noice
-pkgver=0.2.r17.g62736bf
+pkgver=0.4.r18.g829bcdd
pkgrel=1
pkgdesc='Small file browser'
arch=('i686' 'x86_64' 'armv6h')
diff --git a/config.h b/config.h
index 80cb48c37abb..af9bcbb641d4 100644
--- a/config.h
+++ b/config.h
@@ -1,8 +1,9 @@
+/* See LICENSE file for copyright and license details. */
#define CWD "cwd: "
#define CURSR " > "
#define EMPTY " "
-int mtimeorder = 0; /* Set to 1 to sort by time in the default case */
+int mtimeorder = 0; /* Set to 1 to sort by time modified */
int idletimeout = 0; /* Screensaver timeout in seconds, 0 to disable */
char *idlecmd = "rain"; /* The screensaver program */
@@ -31,8 +32,6 @@ struct key bindings[] = {
/* Filter */
{ '/', SEL_FLTR },
{ '&', SEL_FLTR },
- /* Filter as you type */
- { '?', SEL_TYPE },
/* Next */
{ 'j', SEL_NEXT },
{ KEY_DOWN, SEL_NEXT },
@@ -57,12 +56,16 @@ struct key bindings[] = {
{ '$', SEL_END },
/* Change dir */
{ 'c', SEL_CD },
+ { '~', SEL_CDHOME },
+ /* Toggle hide .dot files */
+ { '.', SEL_TOGGLEDOT },
/* Toggle sort by time */
{ 't', SEL_MTIME },
{ CONTROL('L'), SEL_REDRAW },
/* Run command */
- { '!', SEL_RUN, "sh" },
- { 'z', SEL_RUN, "top" },
+ { 'z', SEL_RUN, "top" },
+ { '!', SEL_RUN, "sh", "SHELL" },
/* Run command with argument */
- { 'e', SEL_RUNARG, "vi" },
+ { 'e', SEL_RUNARG, "vi", "EDITOR" },
+ { 'p', SEL_RUNARG, "less", "PAGER" },
};