summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Kromlinger2021-05-17 20:29:16 +0200
committerJustin Kromlinger2021-05-17 20:29:16 +0200
commitac816bf38000eea79291f41e6ffafe336dd95be7 (patch)
tree695497973e3f17714e2426e93088347254a27a1d
parent0d0edebd66b95ca9eb2ed3775698f4cf1a145145 (diff)
downloadaur-ac816bf38000eea79291f41e6ffafe336dd95be7.tar.gz
Switch to VCS source, remove any source code modifications
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD42
-rw-r--r--main.patch10
-rw-r--r--version.go3
4 files changed, 23 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb1674ca9930..46adee93de78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
pkgbase = noisetorch
pkgdesc = Real-time microphone noise suppression on Linux.
pkgver = 0.10.1
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/lawl/NoiseTorch
install = noisetorch.install
arch = x86_64
license = GPL3
makedepends = go
makedepends = cmake
+ makedepends = git
depends = pulseaudio
depends = polkit
provides = noisetorch
- source = 0.10.1-4.tar.gz::https://github.com/lawl/NoiseTorch/archive/0.10.1.tar.gz
+ source = git+https://github.com/lawl/NoiseTorch#tag=0.10.1
source = noisetorch.install
- source = main.patch
- source = version.go
- sha256sums = 72094ec448a19d30865434947f8518cc3510971d27f4f363d4ed22bbf8bb5685
+ sha256sums = SKIP
sha256sums = 171a4179c7e0f3a018a314893e81e598c02cfee274c90d715a302660af920eba
- sha256sums = a1d53c1887ba05f7d7fdb70d275106a0cf39652d55a86c265c917eff00ec6cc9
- sha256sums = 1f2f114638a818fe87ad10b9c7eab91f75f75f1d4e49c0a69f989f76a0d9d0a2
pkgname = noisetorch
diff --git a/PKGBUILD b/PKGBUILD
index e816aa00e626..95e0a08cd638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,31 @@
# Maintainer: Travis Collins <erbrecht at pobox dot com>
-pkgname='noisetorch'
+# Contributor: Justin Kromlinger <hashworks@archlinux.org>
+
+# Note: The upstream maintainer does not allow ANY modifications
+# to the source code. Please refrain from doing so.
+# https://lists.archlinux.org/pipermail/aur-general/2021-May/036230.html
+
+pkgname=noisetorch
pkgver=0.10.1
-pkgrel=4
+pkgrel=5
pkgdesc='Real-time microphone noise suppression on Linux.'
arch=('x86_64')
url=https://github.com/lawl/NoiseTorch
license=('GPL3')
depends=('pulseaudio' 'polkit')
-makedepends=('go' 'cmake')
+makedepends=('go' 'cmake' 'git')
provides=('noisetorch')
install="${pkgname}.install"
-source=("${pkgver}-${pkgrel}.tar.gz::https://github.com/lawl/NoiseTorch/archive/${pkgver}.tar.gz"
- "${pkgname}.install"
- "main.patch"
- "version.go")
-sha256sums=('72094ec448a19d30865434947f8518cc3510971d27f4f363d4ed22bbf8bb5685'
- '171a4179c7e0f3a018a314893e81e598c02cfee274c90d715a302660af920eba'
- 'a1d53c1887ba05f7d7fdb70d275106a0cf39652d55a86c265c917eff00ec6cc9'
- '1f2f114638a818fe87ad10b9c7eab91f75f75f1d4e49c0a69f989f76a0d9d0a2')
-
-prepare() {
- cd NoiseTorch-${pkgver}
- mkdir -p bin/
- patch -u main.go ../main.patch
- sed "s/VERSIONTOKEN/${pkgver}/" ../version.go > version.go
- export GOPATH="$srcdir/go"
-}
+source=("git+${url}#tag=${pkgver}"
+ "${pkgname}.install")
+sha256sums=('SKIP'
+ '171a4179c7e0f3a018a314893e81e598c02cfee274c90d715a302660af920eba')
build() {
- cd NoiseTorch-${pkgver}/c/ladspa
+ export GOPATH="$srcdir/go"
+ cd NoiseTorch/c/ladspa
make
- cd ${srcdir}/NoiseTorch-${pkgver}
+ cd ${srcdir}/NoiseTorch
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
@@ -42,9 +37,10 @@ build() {
}
package() {
- cd NoiseTorch-${pkgver}
+ cd NoiseTorch
install -D -m755 bin/noisetorch "${pkgdir}/usr/bin/noisetorch"
- sed -i 's/noisetorch.png/noisetorch/g' "assets/noisetorch.desktop"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 assets/noisetorch.desktop "${pkgdir}/usr/share/applications/noisetorch.desktop"
+ install -D -m644 assets/icon/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/icon-LICENSE"
install -D -m644 assets/icon/noisetorch.png "${pkgdir}/usr/share/icons/hicolor/256x256/apps/noisetorch.png"
}
diff --git a/main.patch b/main.patch
deleted file mode 100644
index 703c9fe5dd17..000000000000
--- a/main.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- main.go 2021-05-16 15:53:15.287331017 -0400
-+++ src/NoiseTorch-0.10.1/main.go 2021-05-16 15:53:21.954164782 -0400
-@@ -25,7 +25,6 @@
- "github.com/aarzilli/nucular/style"
- )
-
--//go:generate go run scripts/embedversion.go
- //go:generate go run scripts/embedlicenses.go
-
- //go:embed c/ladspa/rnnoise_ladspa.so
diff --git a/version.go b/version.go
deleted file mode 100644
index 2bd53dcb7957..000000000000
--- a/version.go
+++ /dev/null
@@ -1,3 +0,0 @@
-package main
-
-var version = "VERSIONTOKEN"