summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2020-07-17 16:48:39 +0200
committerYour Name2020-07-17 16:48:39 +0200
commitc28c74079eab34e881b75f5d0c70ea7e8a8ac679 (patch)
tree30ba5d35db700506c3f250506ad9aa515c568e73
downloadaur-c28c74079eab34e881b75f5d0c70ea7e8a8ac679.tar.gz
commit message
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8e68b5ffb56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = noisetorch
+ pkgdesc = Real-time microphone noise suppression on Linux.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/lawl/NoiseTorch
+ arch = any
+ license = GPL3
+ makedepends = go
+ makedepends = cmake
+ depends = pulseaudio
+ source = git+https://github.com/lawl/NoiseTorch.git
+ md5sums = SKIP
+
+pkgname = noisetorch
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..612bb3c7e3f0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+upload.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd15e8cea071
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer alx365
+pkgname='noisetorch'
+pkgbase='noisetorch'
+pkgdesc='Real-time microphone noise suppression on Linux.'
+pkgver='1.0'
+pkgrel='1'
+arch=('any')
+url=https://github.com/lawl/NoiseTorch
+license=('GPL3')
+depends=('pulseaudio')
+makedepends=('go' 'cmake')
+md5sums=('SKIP')
+source=('git+https://github.com/lawl/NoiseTorch.git')
+
+build() {
+ pwd
+ cd NoiseTorch
+ pwd
+ git submodule init
+ git submodule update
+ go run scripts/signer.go -g
+ pwd
+ #cd ..
+ make release
+
+}
+
+package() {
+ pwd
+ cd NoiseTorch/bin
+ tar -C $HOME -xzf NoiseTorch_x64.tgz
+ echo "currently you can't use the audo updater. Because you compiled it from source."
+}