summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-09-21 21:56:24 +0200
committerFabioLolix2023-09-21 21:56:24 +0200
commita12a6645a69fa7296a5d8596694531088d89e0fe (patch)
treebe091be95caa27a4e2710b61d14e4f4f52b9ef27
parent24a3a07dedbe2656463ed478ac1dad8137de06c4 (diff)
downloadaur-a12a6645a69fa7296a5d8596694531088d89e0fe.tar.gz
v3.17.2285
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD32
2 files changed, 17 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cb8630ef7a2..d461eb20dd08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nomacs
pkgdesc = A Qt image viewer
- pkgver = 3.17.2282
- pkgrel = 3
+ pkgver = 3.17.2285
+ pkgrel = 1
epoch = 1
url = https://nomacs.org/
arch = x86_64
@@ -19,13 +19,11 @@ pkgbase = nomacs
depends = opencv
depends = qt5-base
depends = qt5-svg
- depends = quazip
+ depends = quazip-qt5
optdepends = qt5-imageformats: support additional image formats
- source = git+https://github.com/nomacs/nomacs.git#tag=3.17.2282
+ source = git+https://github.com/nomacs/nomacs.git#tag=3.17.2285
source = nomacs-plugins-3.16.tar.gz::https://github.com/nomacs/nomacs-plugins/archive/3.16.tar.gz
- source = https://github.com/nomacs/nomacs/files/11703502/nomacs-fix-exiv2-0.28.patch.txt
b2sums = SKIP
b2sums = 2bda4f36d56709653f6696af3404e416fd2d9fe7fa11de9636643c728028018ac769df3e2e519799322c5c42006cdc114d0e6406f9f60294234b07d9fd8d8409
- b2sums = 7144b3e3391047bf89df4da8b78cf0b9273ff7cb2db8637f719ac4b926290901ba3f6f2dee4ba342f8dac4939b4d60be3d80a45dd2481d25408e712160a1bb78
pkgname = nomacs
diff --git a/PKGBUILD b/PKGBUILD
index 86909bc04917..bfc305d21c0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,48 +4,42 @@
_plugins_pkgver=3.16
pkgname=nomacs
-pkgver=3.17.2282
-pkgrel=3
+pkgver=3.17.2285
+pkgrel=1
epoch=1
pkgdesc="A Qt image viewer"
arch=(x86_64)
url="https://nomacs.org/"
license=(GPL3)
-depends=(exiv2 gcc-libs glibc libraw libtiff opencv qt5-base qt5-svg quazip)
+depends=(exiv2 gcc-libs glibc libraw libtiff opencv qt5-base qt5-svg quazip-qt5)
makedepends=(cmake git git-lfs qt5-tools python)
optdepends=('qt5-imageformats: support additional image formats')
source=("git+https://github.com/nomacs/nomacs.git#tag=${pkgver}"
- "nomacs-plugins-${_plugins_pkgver}.tar.gz::https://github.com/nomacs/nomacs-plugins/archive/${_plugins_pkgver}.tar.gz"
- "https://github.com/nomacs/nomacs/files/11703502/nomacs-fix-exiv2-0.28.patch.txt")
+ "nomacs-plugins-${_plugins_pkgver}.tar.gz::https://github.com/nomacs/nomacs-plugins/archive/${_plugins_pkgver}.tar.gz")
b2sums=('SKIP'
- '2bda4f36d56709653f6696af3404e416fd2d9fe7fa11de9636643c728028018ac769df3e2e519799322c5c42006cdc114d0e6406f9f60294234b07d9fd8d8409'
- '7144b3e3391047bf89df4da8b78cf0b9273ff7cb2db8637f719ac4b926290901ba3f6f2dee4ba342f8dac4939b4d60be3d80a45dd2481d25408e712160a1bb78')
+ '2bda4f36d56709653f6696af3404e416fd2d9fe7fa11de9636643c728028018ac769df3e2e519799322c5c42006cdc114d0e6406f9f60294234b07d9fd8d8409')
export GIT_LFS_SKIP_SMUDGE=1
prepare() {
cd "nomacs"
- # https://github.com/nomacs/nomacs/issues/951
- patch -Np1 -i ../nomacs-fix-exiv2-0.28.patch.txt
# copy plugin sources into place
cp -av "${srcdir}/nomacs-plugins-${_plugins_pkgver}/"* "ImageLounge/plugins"
}
build() {
- cd "nomacs"
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cd nomacs
+ cmake -B build -S ImageLounge -Wno-dev \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_SYSTEM_QUAZIP=ON \
-DENABLE_AVIF=ON \
- -DENABLE_TRANSLATIONS=ON \
- -W no-dev \
- -B build \
- -S ./ImageLounge
- make VERBOSE=1 -C build
+ -DENABLE_TRANSLATIONS=ON
+
+ cmake --build build
}
package() {
- cd "nomacs"
- make DESTDIR="${pkgdir}" install -C build
+ cd nomacs
+ DESTDIR="$pkgdir" cmake --install build
}