summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2016-01-13 12:21:09 +0100
committerPeter Mattern2016-01-13 12:21:56 +0100
commit9579d8bbf7574b2fc5565d3bb4403d6727ee9b5f (patch)
tree3992b34714de471f84bec83b2443437d19bdb226
downloadaur-9579d8bbf7574b2fc5565d3bb4403d6727ee9b5f.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD35
-rw-r--r--nomacs-git.install11
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb88ac349bd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Wed Jan 13 11:21:38 UTC 2016
+pkgbase = nomacs-git
+ pkgdesc = Free, open source image viewer, which supports multiple platforms.
+ pkgver = 3.0.0.38.g8aa3448
+ pkgrel = 1
+ url = http://nomacs.org
+ install = nomacs-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = qt5-svg
+ depends = exiv2
+ depends = libraw
+ depends = opencv
+ depends = desktop-file-utils
+ provides = nomacs
+ conflicts = nomacs
+ source = git+https://github.com/nomacs/nomacs.git
+ sha256sums = SKIP
+
+pkgname = nomacs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca301787c64e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+_pkgname=nomacs
+pkgname=$_pkgname-git
+pkgver=3.0.0.38.g8aa3448
+pkgrel=1
+pkgdesc="Free, open source image viewer, which supports multiple platforms."
+arch=("i686" "x86_64")
+url="http://nomacs.org"
+license=("GPL3")
+depends=("qt5-svg" "exiv2" "libraw" "opencv" "desktop-file-utils")
+makedepends=("git" "cmake" "qt5-tools")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+install="$pkgname.install"
+source=("git+https://github.com/$_pkgname/$_pkgname.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname/ImageLounge" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}
diff --git a/nomacs-git.install b/nomacs-git.install
new file mode 100644
index 000000000000..df3df28afe33
--- /dev/null
+++ b/nomacs-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}