summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Langlois2019-12-29 14:34:08 -0700
committerTyler Langlois2019-12-29 14:35:10 -0700
commit8437dcafb825c66f9d878c3c0dd26df99d80be34 (patch)
treeaf1ca962b62169054468331ac58b2fedd6eb84d9
parenteed723d8dbbc0ef28704affe3da48d87f95dae95 (diff)
downloadaur-8437dcafb825c66f9d878c3c0dd26df99d80be34.tar.gz
Add support for additional non-x86_64 architectures
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 4 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1a18b62aa4a..c7851aee9668 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,6 +4,9 @@ pkgbase = nomad
pkgrel = 1
url = https://nomadproject.io/
arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv7l
license = MPL2
makedepends = go
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index cecc9fe35f09..e0b45b876cfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=nomad
pkgver=0.10.2
pkgrel=1
pkgdesc="A Distributed, Highly Available, Datacenter-Aware Scheduler"
-arch=('x86_64')
+arch=('x86_64' 'aarch64' 'armv7h' 'armv7l')
url="https://nomadproject.io/"
license=('MPL2')
#depends=('ethtool' 'lxc')
@@ -32,12 +32,6 @@ prepare() {
export GOPATH="$srcdir"
export PATH="$GOPATH/bin:$PATH"
- if [ $CARCH == "x86_64" ]; then
- export GOARCH=amd64
- else
- export GOARCH=386
- fi
-
go get golang.org/x/sys/cpu
make deps lint-deps
@@ -49,12 +43,6 @@ build() {
export GOPATH="$srcdir"
export PATH="$GOPATH/bin:$PATH"
- if [ $CARCH == "x86_64" ]; then
- export GOARCH=amd64
- else
- export GOARCH=386
- fi
-
CGO_ENABLED=1 \
go build -ldflags '-X main.GitCommit=""' \
-tags "ui lxc" \