summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBao Trinh2023-04-12 08:06:35 -0500
committerBao Trinh2023-04-12 08:10:54 -0500
commit8c45c4168374be7f937411593e9396ab172e5f34 (patch)
tree64ee4d4dd99bfb263152a5859e3ac3652772b439
parent4dd9e65055ae51c232df2521d5f45dfd49979a2b (diff)
downloadaur-8c45c4168374be7f937411593e9396ab172e5f34.tar.gz
make consistent with official package
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD32
3 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91d2bd2c3735..5253da27a42e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nomad-driver-podman-git
pkgdesc = A nomad taskdriver for podman containers
- pkgver = v0.4.0.r21.g39a4a50
+ pkgver = 0.4.2.r10.gaeed282
pkgrel = 1
url = https://github.com/hashicorp/nomad-driver-podman
arch = x86_64
@@ -11,7 +11,9 @@ pkgbase = nomad-driver-podman-git
depends = podman
provides = nomad-driver-podman
conflicts = nomad-driver-podman
- source = nomad-driver-podman-git::git+https://github.com/hashicorp/nomad-driver-podman
+ options = !lto
+ options = debug
+ source = nomad-driver-podman::git+https://github.com/hashicorp/nomad-driver-podman
md5sums = SKIP
pkgname = nomad-driver-podman-git
diff --git a/.gitignore b/.gitignore
index ebc9ae0a3d53..fd5955d77d3d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
pkg/
src/
-nomad-driver-podman-git/
+nomad-driver-podman/
nomad-driver-podman-git-*pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 0a6ae56c1527..01f0394519c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=nomad-driver-podman
pkgname=${_pkgname}-git
-pkgver=v0.4.0.r21.g39a4a50
+pkgver=0.4.2.r10.gaeed282
pkgrel=1
pkgdesc="A nomad taskdriver for podman containers"
arch=('x86_64')
@@ -11,24 +11,32 @@ url="https://github.com/hashicorp/nomad-driver-podman"
license=('MPL2')
depends=('nomad' 'podman')
makedepends=('go' 'git')
+options=('!lto')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("$pkgname::git+https://github.com/hashicorp/nomad-driver-podman")
+source=("${_pkgname}::git+${url}")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- git describe --long --tags --match'=v[0-9]*' | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${_pkgname}"
+
+ git describe --long --tags --match'=v[0-9]*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/$pkgname"
+ cd "${_pkgname}"
+
+ # create directory for build output
mkdir -p build
+
+ # download dependencies
+ go mod download
}
build() {
- cd "$srcdir/$pkgname"
- go build \
+ cd "${_pkgname}"
+
+ go build -v \
-trimpath \
-buildmode=pie \
-mod=readonly \
@@ -39,14 +47,14 @@ build() {
}
package() {
- cd "$srcdir/$pkgname"
+ cd "${_pkgname}"
# binary
- install -vDm755 -t "$pkgdir/usr/lib/nomad/plugins" "build/$_pkgname"
+ install -vDm755 -t "$pkgdir/usr/lib/nomad/plugins" "build/${_pkgname}"
# documentation
- install -vDm644 -t "$pkgdir/usr/share/doc/$_pkgname" README.md
- cp -vr examples "$pkgdir/usr/share/doc/$_pkgname"
+ install -vDm644 -t "$pkgdir/usr/share/doc/${_pkgname}" README.md
+ cp -vr examples "$pkgdir/usr/share/doc/${_pkgname}"
# note: examples/plugins is an empty folder
- rm -rf "$pkgdir/usr/share/doc/$_pkgname/examples/plugins"
+ rm -rf "$pkgdir/usr/share/doc/${_pkgname}/examples/plugins"
}