summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12018-08-28 13:49:49 +0800
committermaz-12018-08-28 13:49:49 +0800
commit1915e3e8ba0142c7167c34bd65f5fc0c1655114f (patch)
treedcc8a281527a1a71f8e4d315d47f78c5e765fa38
downloadaur-1915e3e8ba0142c7167c34bd65f5fc0c1655114f.tar.gz
init
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD42
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe513473e3b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = nomad-firewall-git
+ pkgdesc = kcm module for ufw from nomad desktop
+ pkgver = 0.1.r68.gfb8937e
+ pkgrel = 1
+ url = https://github.com/nomad-desktop/nomad-firewall
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ depends = kdeclarative
+ depends = kcoreaddons
+ depends = kcmutils
+ depends = ki18n
+ depends = plasma-framework
+ depends = kdelibs4support
+ depends = kauth
+ depends = kconfig
+ depends = kio
+ depends = knewstuff
+ depends = kconfigwidgets
+ depends = net-tools
+ depends = ufw
+ source = git+https://github.com/nomad-desktop/nomad-firewall.git
+ md5sums = SKIP
+
+pkgname = nomad-firewall-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b24ce1f8952
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+
+# Maintainer: maz-1 <ohmygod19993 at gmail dot com>
+
+_pkgname=nomad-firewall
+pkgname=nomad-firewall-git
+pkgver=0.1.r68.gfb8937e
+pkgrel=1
+pkgdesc="kcm module for ufw from nomad desktop"
+arch=('i686' 'x86_64')
+url="https://github.com/nomad-desktop/nomad-firewall"
+license=('GPL2')
+depends=('kdeclarative' 'kcoreaddons' 'kcmutils' 'ki18n' 'plasma-framework' 'kdelibs4support'
+ 'kauth' 'kconfig' 'kio' 'knewstuff' 'kconfigwidgets' 'net-tools' 'ufw')
+makedepends=('git' 'extra-cmake-modules' 'kdoctools')
+source=('git+https://github.com/nomad-desktop/nomad-firewall.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_LIBEXECDIR=lib \
+ -DKDE_INSTALL_SYSCONFDIR=/etc \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir/" install
+ ln -s kcms/org.nxos.firewall.so "$pkgdir/usr/lib/qt/plugins/org.nxos.firewall.so"
+}