summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Schichtel2023-07-07 23:57:28 +0200
committerPhillip Schichtel2023-07-07 23:57:28 +0200
commit43de616d20267333b3be593b691b45b2f6eb2b62 (patch)
treed52972e94798b3af960e768fa97b60e6f663e8c9
downloadaur-43de616d20267333b3be593b691b45b2f6eb2b62.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--Makefile12
-rw-r--r--PKGBUILD31
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3248a5ba175
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nomad-pack-nightly
+ pkgdesc = A templating and packaging tool used with HashiCorp Nomad.
+ pkgver = v0.0.1.techpreview2.r80.g50d84d0
+ pkgrel = 1
+ url = https://github.com/hashicorp/nomad-pack
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MPL2
+ makedepends = git
+ makedepends = go
+ depends = openssl
+ depends = git
+ source = git+https://github.com/hashicorp/nomad-pack.git#tag=nightly
+ validpgpkeys = 5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23
+ sha256sums = SKIP
+
+pkgname = nomad-pack-nightly
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0c0e3162fd2a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+nomad-pack/
+LICENSE
+*.asc
+*.tar.*
+src/
+pkg/
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..cbd793708534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,12 @@
+
+.SRCINFO: PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+package: PKGBUILD .SRCINFO
+ updpkgsums
+ makepkg --syncdeps --rmdeps --force --clean --noconfirm
+
+all: package
+
+clean:
+ rm -fRv .SRCINFO *.tar.* nomad-pack/ src/ pkg/ *.asc 2> /dev/null || true
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bafa4bddc0d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Phillip Schichtel <phillip@schich.tel>
+
+pkgname=nomad-pack-nightly
+pkgver=v0.0.1.techpreview2.r80.g50d84d0
+pkgrel=1
+pkgdesc="A templating and packaging tool used with HashiCorp Nomad."
+arch=('x86_64' 'armv7h' 'aarch64')
+url="https://github.com/hashicorp/nomad-pack"
+license=('MPL2')
+depends=(openssl git)
+makedepends=(git go)
+validpgpkeys=(5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23)
+source=("git+https://github.com/hashicorp/nomad-pack.git#tag=nightly")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/nomad-pack"
+ git describe --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ local version="$(pkgver)"
+ cd "$srcdir/nomad-pack"
+ export CGO_ENABLED=0
+ go build -ldflags "-X '$(go list -m)/internal/pkg/version.GitDescribe=${version}'" -trimpath
+}
+
+package() {
+ install -D -m755 "$srcdir/nomad-pack/nomad-pack" "$pkgdir/usr/bin/nomad-pack"
+}
+