summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Schichtel2023-07-10 11:57:24 +0200
committerPhillip Schichtel2023-07-10 11:57:24 +0200
commit5c629c3a7e7f82c3320674bb4ba06179003b805a (patch)
tree429e8b7a69e2fa441ff27bb3e76b5706a544cd65
parent43de616d20267333b3be593b691b45b2f6eb2b62 (diff)
downloadaur-5c629c3a7e7f82c3320674bb4ba06179003b805a.tar.gz
add bash completion
-rw-r--r--PKGBUILD10
-rw-r--r--bash-completion.sh2
2 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bafa4bddc0d2..0d48109e4b5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,9 +9,12 @@ url="https://github.com/hashicorp/nomad-pack"
license=('MPL2')
depends=(openssl git)
makedepends=(git go)
+optdepends=(bash-completion)
validpgpkeys=(5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23)
-source=("git+https://github.com/hashicorp/nomad-pack.git#tag=nightly")
-sha256sums=('SKIP')
+source=("git+https://github.com/hashicorp/nomad-pack.git#tag=nightly"
+ "bash-completion.sh")
+sha256sums=('SKIP'
+ 'ac6a0c1f54833f4706ec7366c570b3088a06ca21128642f21435a7f464b98129')
pkgver() {
cd "$srcdir/nomad-pack"
@@ -27,5 +30,8 @@ build() {
package() {
install -D -m755 "$srcdir/nomad-pack/nomad-pack" "$pkgdir/usr/bin/nomad-pack"
+ local bash_completions_dir="$pkgdir/usr/share/bash-completion/completions"
+ install -D -d -m755 "$bash_completions_dir"
+ install -m644 "$srcdir/bash-completion.sh" "$bash_completions_dir/nomad-pack"
}
diff --git a/bash-completion.sh b/bash-completion.sh
new file mode 100644
index 000000000000..e84ea86c6726
--- /dev/null
+++ b/bash-completion.sh
@@ -0,0 +1,2 @@
+complete -C /usr/bin/nomad-pack nomad-pack
+