summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNavid2022-07-11 06:27:21 +0430
committerNavid2022-07-11 06:40:10 +0430
commit53d28e59e65b8de1145d912c04286a05b0ddb3b3 (patch)
treed989524f6812d6e7366c39c9431183719821e934
parent61c24bc0717e0fc6ebf602a512f11c1ae999496c (diff)
downloadaur-53d28e59e65b8de1145d912c04286a05b0ddb3b3.tar.gz
Use cargo install to build package
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3a286306eb4..9198757f8122 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = nomino
pkgdesc = Batch rename utility for developers
pkgver = 1.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/yaa110/nomino
arch = i686
arch = x86_64
license = MIT
- makedepends = rust
- makedepends = python3
+ makedepends = cargo
depends = gcc-libs
provides = nomino
- conflicts = nomino-bin
source = 1.2.1.tar.gz::https://github.com/yaa110/nomino/archive/1.2.1.tar.gz
sha512sums = 522d549c49b98fa84e18130c242615a282dd57a112414fc4172d08f6261ad2b675a4f2c82368dae3a2f978363dac6044f9e5d9fef1d7db75d2066b9e36104fd3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4256d2670823
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.gz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 1c9aca93c3e7..da89f98dfaa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,24 @@
pkgname=nomino
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="https://github.com/yaa110/nomino"
license=("MIT")
-
pkgdesc='Batch rename utility for developers'
-
-source=("$pkgver.tar.gz::https://github.com/yaa110/$pkgname/archive/$pkgver.tar.gz")
-sha512sums=('522d549c49b98fa84e18130c242615a282dd57a112414fc4172d08f6261ad2b675a4f2c82368dae3a2f978363dac6044f9e5d9fef1d7db75d2066b9e36104fd3')
-makedepends=('rust' 'python3')
+makedepends=('cargo')
depends=('gcc-libs')
-conflicts=('nomino-bin')
provides=('nomino')
+source=("$pkgver.tar.gz::https://github.com/yaa110/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('522d549c49b98fa84e18130c242615a282dd57a112414fc4172d08f6261ad2b675a4f2c82368dae3a2f978363dac6044f9e5d9fef1d7db75d2066b9e36104fd3')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- RUSTFLAGS='-C link-args=-s' cargo build -j`nproc` --release
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build -j`nproc` --release
}
package() {
- install -Dm755 "$pkgname-$pkgver/target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 "$pkgname-$pkgver/LICENSE-MIT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "$pkgname-$pkgver/target/release/$pkgname"
}
-