summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-12 18:58:48 +0800
committerzxp198210052023-12-12 18:58:48 +0800
commit0cc9f9ce12aba88ec08d0f3bca7c5deb0081fe4f (patch)
treeb572cf47d09d98c3456a788e3463788677488868
parent47c64f4476e988daf810a589d115cc57e8628dac (diff)
downloadaur-0cc9f9ce12aba88ec08d0f3bca7c5deb0081fe4f.tar.gz
fix errors
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f60b968e6475..3af7d18b6bfa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = nomino-bin
pkgdesc = Batch rename utility for developers
pkgver = 1.3.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/yaa110/nomino
arch = x86_64
license = Apache
license = MIT
- depends = gcc-libs
- depends = glibc
provides = nomino=1.3.3
conflicts = nomino
source = nomino-1.3.3::https://github.com/yaa110/nomino/releases/download/1.3.3/nomino-linux-64bit
- source = LICENSE-MIT::https://raw.githubusercontent.com/yaa110/nomino/1.3.3/LICENSE-MIT
- source = LICENSE-APACHE::https://raw.githubusercontent.com/yaa110/nomino/1.3.3/LICENSE-APACHE
+ source = LICENSE-MIT-1.3.3::https://raw.githubusercontent.com/yaa110/nomino/1.3.3/LICENSE-MIT
+ source = LICENSE-APACHE-1.3.3::https://raw.githubusercontent.com/yaa110/nomino/1.3.3/LICENSE-APACHE
sha256sums = ade222b0232367960bfdf891c6e34356a393d7624c33d60f7979c07b2f6893bf
sha256sums = c61849f2f67590dc6e6a865e273accfd56a337ae29bc30c93ecaf50bc7bab77f
sha256sums = 0beb66d48e2a5702f0f1d8c8f62cce5877410c85eed400952db3d58a759935ef
diff --git a/PKGBUILD b/PKGBUILD
index d90389a11195..170be580fce1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,24 @@
# Contributor: yaa110 <yaa110@gmail.com>
pkgname=nomino-bin
pkgver=1.3.3
-pkgrel=1
+pkgrel=2
pkgdesc='Batch rename utility for developers'
arch=('x86_64')
url="https://github.com/yaa110/nomino"
license=('Apache' 'MIT')
-depends=('gcc-libs' 'glibc')
+depends=()
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-source=("${pkgname%-bin}-${pkgver}::${url}/releases/download/${pkgver}/${pkgname%-bin}-linux-64bit"
- "LICENSE-MIT::https://raw.githubusercontent.com/yaa110/nomino/${pkgver}/LICENSE-MIT"
- "LICENSE-APACHE::https://raw.githubusercontent.com/yaa110/nomino/${pkgver}/LICENSE-APACHE")
+source=(
+ "${pkgname%-bin}-${pkgver}::${url}/releases/download/${pkgver}/${pkgname%-bin}-linux-64bit"
+ "LICENSE-MIT-${pkgver}::https://raw.githubusercontent.com/yaa110/nomino/${pkgver}/LICENSE-MIT"
+ "LICENSE-APACHE-${pkgver}::https://raw.githubusercontent.com/yaa110/nomino/${pkgver}/LICENSE-APACHE"
+)
sha256sums=('ade222b0232367960bfdf891c6e34356a393d7624c33d60f7979c07b2f6893bf'
'c61849f2f67590dc6e6a865e273accfd56a337ae29bc30c93ecaf50bc7bab77f'
'0beb66d48e2a5702f0f1d8c8f62cce5877410c85eed400952db3d58a759935ef')
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}-${pkgver}" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/LICENSE"* -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE-MIT-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
+ install -Dm644 "${srcdir}/LICENSE-APACHE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-APACHE"
} \ No newline at end of file