summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-05 10:36:01 +0800
committerzxp198210052023-07-05 10:36:01 +0800
commit6658f95d6165feaf353810cc3b0ccbd01d83b868 (patch)
treeb51cb0527130cadf4c5080023ee828e2f175310d
parentea8778b99793924586a5e93bd043ba7571ccbce5 (diff)
downloadaur-6658f95d6165feaf353810cc3b0ccbd01d83b868.tar.gz
update to 1.3.1
-rw-r--r--.SRCINFO11
-rw-r--r--LICENSE25
-rw-r--r--PKGBUILD32
3 files changed, 24 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f941296a230b..dc1944f6b994 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = nomino-bin
pkgdesc = Batch rename utility for developers
- pkgver = 1.2.2
+ pkgver = 1.3.1
pkgrel = 1
url = https://github.com/yaa110/nomino
arch = x86_64
license = Apache
license = MIT
depends = gcc-libs
+ depends = glibc
provides = nomino
conflicts = nomino
- source = LICENSE
+ source = nomino-1.3.1::https://github.com/yaa110/nomino/releases/download/1.3.1/nomino-linux-64bit
+ source = LICENSE-MIT::https://raw.githubusercontent.com/yaa110/nomino/master/LICENSE-MIT
+ source = LICENSE-APACHE::https://raw.githubusercontent.com/yaa110/nomino/master/LICENSE-APACHE
+ sha256sums = 7bceb645e53acb5dff82b4e1cec9e5d568336326b8c89e4870fdbe62dc80547d
sha256sums = c61849f2f67590dc6e6a865e273accfd56a337ae29bc30c93ecaf50bc7bab77f
- source_x86_64 = nomino-1.2.2-x86_64::https://github.com/yaa110/nomino/releases/download/1.2.2/nomino-linux-64bit
- sha256sums_x86_64 = 67dfa6de30efee0eaa935a8151e40002951dd13fbbd77f131c839cf431af411d
+ sha256sums = 0beb66d48e2a5702f0f1d8c8f62cce5877410c85eed400952db3d58a759935ef
pkgname = nomino-bin
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 85f9582a9519..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,25 +0,0 @@
-Copyright (c) 2020 Navid Fathollahzade
-
-Permission is hereby granted, free of charge, to any
-person obtaining a copy of this software and associated
-documentation files (the "Software"), to deal in the
-Software without restriction, including without
-limitation the rights to use, copy, modify, merge,
-publish, distribute, sublicense, and/or sell copies of
-the Software, and to permit persons to whom the Software
-is furnished to do so, subject to the following
-conditions:
-
-The above copyright notice and this permission notice
-shall be included in all copies or substantial portions
-of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
-ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
-TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
-PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
-SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
-CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
-OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
-IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
-DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 641c234d75f6..d01407abf086 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: yaa110 <yaa110@gmail.com>
-
pkgname=nomino-bin
-_pkgname="${pkgname%-bin}"
-pkgver=1.2.2
+pkgver=1.3.1
pkgrel=1
pkgdesc='Batch rename utility for developers'
arch=('x86_64')
url="https://github.com/yaa110/nomino"
license=('Apache' 'MIT')
-depends=('gcc-libs')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=('LICENSE')
-source_x86_64=("$_pkgname-$pkgver-x86_64::$url/releases/download/$pkgver/$_pkgname-linux-64bit")
-sha256sums=('c61849f2f67590dc6e6a865e273accfd56a337ae29bc30c93ecaf50bc7bab77f')
-sha256sums_x86_64=('67dfa6de30efee0eaa935a8151e40002951dd13fbbd77f131c839cf431af411d')
-
+depends=('gcc-libs' 'glibc')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}::https://github.com/yaa110/nomino/releases/download/1.3.1/nomino-linux-64bit"
+ "LICENSE-MIT::https://raw.githubusercontent.com/yaa110/nomino/master/LICENSE-MIT"
+ "LICENSE-APACHE::https://raw.githubusercontent.com/yaa110/nomino/master/LICENSE-APACHE")
+sha256sums=('7bceb645e53acb5dff82b4e1cec9e5d568336326b8c89e4870fdbe62dc80547d'
+ 'c61849f2f67590dc6e6a865e273accfd56a337ae29bc30c93ecaf50bc7bab77f'
+ '0beb66d48e2a5702f0f1d8c8f62cce5877410c85eed400952db3d58a759935ef')
package() {
- install -D "$_pkgname-$pkgver-$CARCH" "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
-}
+ install -Dm0755 "${srcdir}/${pkgname%-bin}-${pkgver}" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm0755 -d "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/LICENSE"* -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file