summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-07-25 09:47:06 -0500
committerLuis Martinez2022-07-25 09:47:06 -0500
commitab9df248c2950a39be101b3ef4bcae21e5fe536d (patch)
tree5594013575a23d4d917e458eb606574f943a70e2
parentcea149c57f239056c342b1737717753b7294329e (diff)
downloadaur-ab9df248c2950a39be101b3ef4bcae21e5fe536d.tar.gz
update to 1.2.1
-rw-r--r--.SRCINFO12
-rw-r--r--LICENSE25
-rw-r--r--PKGBUILD30
3 files changed, 45 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b88b868a00c5..b464ea57af26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = nomino-bin
pkgdesc = Batch rename utility for developers
- pkgver = 0.4.2
+ pkgver = 1.2.1
pkgrel = 1
url = https://github.com/yaa110/nomino
arch = x86_64
+ license = Apache
license = MIT
depends = gcc-libs
provides = nomino
conflicts = nomino
- source = LICENSE::https://raw.githubusercontent.com/yaa110/nomino/master/LICENSE-MIT
- sha512sums = 169b314c09dffe76c8bf31929a61e58358c66516c17629cb257e0d44101b78d3949ee6d9951bb813cd6348d8626a0c8f638f6f874db446dce87cfa1de24d39ba
- source_x86_64 = https://github.com/yaa110/nomino/releases/download/0.4.2/nomino-linux-64bit
- sha512sums_x86_64 = 0cd43401476060dca6d462fc5028f61f4ac062cc3aac828e30da895b9ebfafbe5acb3d04184271cb66941ee58a6d10339bdb7f2ae8f087cff062938fa08c6222
+ source = LICENSE
+ sha256sums = c61849f2f67590dc6e6a865e273accfd56a337ae29bc30c93ecaf50bc7bab77f
+ source_x86_64 = nomino-1.2.1-x86_64::https://github.com/yaa110/nomino/releases/download/1.2.1/nomino-linux-64bit
+ sha256sums_x86_64 = bbbcefb8a8f1ece37c66f20d901725069fcbed8f5e3664467992ae2ec8296bb6
pkgname = nomino-bin
-
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..85f9582a9519
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,25 @@
+Copyright (c) 2020 Navid Fathollahzade
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index d6c3f91a59ee..c36bef3d49c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-# Maintainer: yaa110 <yaa110@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: yaa110 <yaa110@gmail.com>
pkgname=nomino-bin
-_pkgname=nomino
-pkgver=0.4.2
+_pkgname="${pkgname%-bin}"
+pkgver=1.2.1
pkgrel=1
+pkgdesc='Batch rename utility for developers'
arch=('x86_64')
url="https://github.com/yaa110/nomino"
-license=("MIT")
-
-pkgdesc='Batch rename utility for developers'
-
-source=("LICENSE::https://raw.githubusercontent.com/yaa110/$_pkgname/master/LICENSE-MIT")
-source_x86_64=("https://github.com/yaa110/$_pkgname/releases/download/$pkgver/$_pkgname-linux-64bit")
-sha512sums=("169b314c09dffe76c8bf31929a61e58358c66516c17629cb257e0d44101b78d3949ee6d9951bb813cd6348d8626a0c8f638f6f874db446dce87cfa1de24d39ba")
-sha512sums_x86_64=("0cd43401476060dca6d462fc5028f61f4ac062cc3aac828e30da895b9ebfafbe5acb3d04184271cb66941ee58a6d10339bdb7f2ae8f087cff062938fa08c6222")
+license=('Apache' 'MIT')
depends=('gcc-libs')
-conflicts=('nomino')
-provides=('nomino')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=('LICENSE')
+source_x86_64=("$_pkgname-$pkgver-x86_64::$url/releases/download/$pkgver/$_pkgname-linux-64bit")
+sha256sums=('c61849f2f67590dc6e6a865e273accfd56a337ae29bc30c93ecaf50bc7bab77f')
+sha256sums_x86_64=('bbbcefb8a8f1ece37c66f20d901725069fcbed8f5e3664467992ae2ec8296bb6')
package() {
- install -Dm755 "$srcdir/$_pkgname-linux-64bit" "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D "$_pkgname-$pkgver-$CARCH" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}
-