summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2022-01-26 00:18:26 +0200
committerAdrian Perez de Castro2022-01-26 00:18:26 +0200
commit1a421cd84df26b9091040af0d57e41ece39024a4 (patch)
tree2003d14482f457248390120177f759403742a3be
downloadaur-1a421cd84df26b9091040af0d57e41ece39024a4.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7e00478aeb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nono
+ pkgdesc = Omron LUNA-I and LUNA-88K emulator
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = http://www.pastel-flower.jp/~isaki/nono
+ arch = x86_64
+ license = custom
+ makedepends = bmake
+ makedepends = clang
+ makedepends = freebsd-mk
+ makedepends = gettext
+ depends = libbsd
+ depends = libkqueue
+ depends = termcap
+ depends = wxgtk3
+ source = http://www.pastel-flower.jp/~isaki/nono/archive/nono-0.2.5.tar.gz
+ b2sums = 55a886b2ab634a34244cf4cd149bc95ce9c7046437715209cb7c3b192c143f651fba20a9a6aec65352f204b9767f0dd1d5b90e1450accb408b8f14d6920c0555
+
+pkgname = nono
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218620e2fb38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efb640f42f88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+pkgdesc='Omron LUNA-I and LUNA-88K emulator'
+pkgname=nono
+pkgver=0.2.5
+pkgrel=1
+url=http://www.pastel-flower.jp/~isaki/nono
+license=(custom)
+arch=(x86_64)
+depends=(libbsd libkqueue termcap wxgtk3)
+makedepends=(bmake clang freebsd-mk gettext)
+source=("${url}/archive/${pkgname}-${pkgver}.tar.gz")
+b2sums=('55a886b2ab634a34244cf4cd149bc95ce9c7046437715209cb7c3b192c143f651fba20a9a6aec65352f204b9767f0dd1d5b90e1450accb408b8f14d6920c0555')
+
+prepare ()
+{
+ # The configure script searches for <kqueue/sys/event.h> instead of the
+ # regular location <sys/event.h> as used by the libkqueue package, so
+ # provide a local directory with the expected layout.
+ mkdir -p "${srcdir}/include/kqueue/"
+ ln -vsnf /usr/include/sys "${srcdir}/include/kqueue/sys"
+}
+
+build ()
+{
+ cd "${pkgname}-${pkgver}"
+
+ # Use Clang because GCC 11+ has some false positive warnings that cause
+ # the compilation to fail due to -Werror. Plus, the BSDs are using Clang
+ # nowadays so using Clang builds is more tested.
+ ./configure \
+ CC=clang \
+ CXX=clang++ \
+ CPPFLAGS="${CPPFLAGS} -I${srcdir}/include" \
+ WX_CONFIG=/usr/bin/wx-config-gtk3 \
+ --prefix=/usr
+
+ # The configuration generated by autoconf does NOT include CPPFLAGS,
+ # so add the include directory for the mangled libkqueue headers now.
+ sed -i "/^C\(C\|XX\)=/s,$, -I${srcdir}/include," \
+ Makefile.cfg
+
+ bmake -DNOTEST -m/usr/share/mk-freebsd
+}
+
+package ()
+{
+ cd "${pkgname}-${pkgver}"
+ bmake -DNOTEST -m/usr/share/mk-freebsd DESTDIR="${pkgdir}" install
+ install -Dm644 doc/nono-license.txt \
+ "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+}