summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2020-04-17 15:41:25 +0200
committerJose Riha2020-04-17 15:41:25 +0200
commit82d9580f80497271c49c9c2eb9502749bae2490f (patch)
treee28a5fa9ecbb585e4a914c855804b43813203e23
downloadaur-82d9580f80497271c49c9c2eb9502749bae2490f.tar.gz
Initial commit
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD39
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d9bb59fe543
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = nootka-git
+ pkgdesc = Tool for learning classical score notation (git)
+ pkgver = r3683.29c8ac7e
+ pkgrel = 1
+ url = http://nootka.sourceforge.net/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = cmake
+ makedepends = qt5-base
+ makedepends = fftw
+ makedepends = libvorbis
+ makedepends = soundtouch
+ makedepends = alsa-lib
+ makedepends = git
+ depends = qt5-base
+ depends = fftw
+ depends = shared-mime-info
+ depends = libvorbis
+ depends = soundtouch
+ depends = alsa-lib
+ optdepends = libpulse: for PulseAudio
+ optdepends = jack: for JACK
+ optdepends = qt5-translations: for other languages support
+ conflicts = nootka
+ conflicts = nootka-hg
+ replaces = nootka-hg
+ source = nootka-git::git+https://www.opencode.net/seelook/nootka.git
+ md5sums = SKIP
+
+pkgname = nootka-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89bb1835423e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=nootka-git
+pkgver=r3683.29c8ac7e
+pkgrel=1
+pkgdesc="Tool for learning classical score notation (git)"
+arch=('x86_64' 'i686')
+url="http://nootka.sourceforge.net/"
+license=('GPL3')
+depends=('qt5-base' 'fftw' 'shared-mime-info' 'libvorbis' 'soundtouch' 'alsa-lib')
+optdepends=(
+'libpulse: for PulseAudio'
+'jack: for JACK'
+'qt5-translations: for other languages support'
+)
+conflicts=('nootka' 'nootka-hg')
+replaces=('nootka-hg')
+makedepends=('cmake' 'qt5-base' 'fftw' 'libvorbis' 'soundtouch' 'alsa-lib' 'git')
+source=("${pkgname}"::'git+https://www.opencode.net/seelook/nootka.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$srcdir/nootka-git"
+ [ ! -d build ] && mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package() {
+ cd "$srcdir/nootka-git/build"
+ make DESTDIR="$pkgdir/" install
+}