summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAthaudia2016-06-23 21:31:44 +0200
committerAthaudia2016-06-23 21:31:44 +0200
commitf38db07351df2dc73b387526eef3940e598d2edd (patch)
tree4cf55f6f81e0eb13e66c8795545c61963fdbad19
downloadaur-nopoll-git.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce77d376cc38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nopoll-git
+ pkgdesc = Websocket library written in C
+ pkgver = r287.b18aef3
+ pkgrel = 1
+ url = http://www.aspl.es/nopoll/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = openssl
+ provides = nopoll
+ conflicts = nopoll
+ source = git+https://github.com/ASPLes/nopoll.git
+ sha1sums = SKIP
+
+pkgname = nopoll-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d933aca8ddf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Athaudia <athaudia at gmail dot com>
+
+set -u
+pkgname='nopoll-git'
+pkgver='r287.b18aef3'
+pkgrel='1'
+pkgdesc='Websocket library written in C'
+arch=('i686' 'x86_64')
+url='http://www.aspl.es/nopoll/'
+license=('LGPL')
+depends=('openssl')
+provides=('nopoll')
+conflicts=('nopoll')
+source=("git+https://github.com/ASPLes/nopoll.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd nopoll
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ set -u
+ cd nopoll
+ sed -i 's/^AM_INIT_AUTOMAKE$/AM_INIT_AUTOMAKE\(\[foreign\]\)/' configure.ac
+ autoreconf -i
+ ./configure --prefix='/usr' --enable-maintainer-mode
+ set +u
+}
+
+build() {
+ set -u
+ cd nopoll
+ make -s -j "$(nproc)"
+ set +u
+}
+
+package() {
+ set -u
+ cd nopoll
+ make DESTDIR="${pkgdir}/" install
+ set +u
+}
+set +u