summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBBaoVanC2021-01-15 16:22:31 -0600
committerBBaoVanC2021-01-15 16:22:31 -0600
commitcdda1ff2e1687bd25a42cf0e513b20cefa3e81ac (patch)
tree1172ecdbd5f7c85e2d7893cebf9cbcaa83cfe2a5
downloadaur-cdda1ff2e1687bd25a42cf0e513b20cefa3e81ac.tar.gz
Add .SRCINFO and PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD70
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c94b4b36401
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nordic-bluish-theme-git
+ pkgdesc = Dark Gtk3.20+ theme created using the awesome Nord color pallete. Bluish accent branch
+ pkgver = r95.cdfef35
+ pkgrel = 1
+ url = https://github.com/EliverLara/Nordic
+ arch = any
+ license = GPL
+ makedepends = inkscape
+ makedepends = optipng
+ optdepends = ttf-roboto: primary font face defined
+ optdepends = ttf-ubuntu-font-family: secondary font face defined
+ optdepends = cantarell-fonts: tertiary font face defined
+ source = Nordic::git+https://github.com/EliverLara/Nordic.git#branch=bluish-accent
+ sha256sums = SKIP
+
+pkgname = nordic-bluish-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53987b755626
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: bbaovanc <bbaovanc@bbaovanc.com>
+# Contributors: Tony Lambiris <tony@libpcap.net>
+
+pkgname=nordic-bluish-theme-git
+_pkgname=Nordic
+_branch=bluish-accent
+pkgver=r95.cdfef35
+pkgrel=1
+pkgdesc="Dark Gtk3.20+ theme created using the awesome Nord color pallete. Bluish accent branch"
+arch=("any")
+url="https://github.com/EliverLara/${_pkgname}"
+license=('GPL')
+makedepends=('inkscape' 'optipng')
+optdepends=('ttf-roboto: primary font face defined'
+ 'ttf-ubuntu-font-family: secondary font face defined'
+ 'cantarell-fonts: tertiary font face defined')
+source=("${_pkgname}::git+https://github.com/EliverLara/${_pkgname}.git#branch=${_branch}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ export THEME_FONT_FACE="${THEME_FONT_FACE:-Roboto}"
+ export THEME_FONT_SIZE="${THEME_FONT_SIZE:-10}"
+
+ msg2 "To customize the font and size for gnome-shell, build this package"
+ msg2 "with the variables below set to the desired font family and size"
+ msg2 "- THEME_FONT_FACE (default font family is Roboto)"
+ msg2 "- THEME_FONT_SIZE (default font point size is 10)"
+ msg2 ""
+ msg2 "Continuing build in 5 seconds..."; sleep 5
+
+ msg2 "Rendering assets, please wait"
+ pushd gtk-2.0
+ while read $line; do echo -n "."; done < \
+ <(./render-assets.sh); echo
+ popd
+
+ pushd src
+ while read $line; do echo -n "."; done < \
+ <(./render-gtk3-assets.py; ./render-gtk3-assets-hidpi.py; ./render-wm-assets-hidpi.py; ./render-wm-assets.py); echo
+ popd
+ msg2 "Done!"
+
+ msg2 "Setting gnome-shell font face to ${THEME_FONT_FACE}"
+ msg2 "Setting gnome-shell font size to ${THEME_FONT_SIZE}"
+
+ if [ "${THEME_FONT_FACE}" != "Roboto" ]; then
+ sed -i -re "s/font-family: (.*);/font-family: ${THEME_FONT_FACE}, \1;/" \
+ "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ fi
+
+ if [ "${THEME_FONT_SIZE}" != "10" ]; then
+ sed -i -re "s/font-size: (.*);/font-size: ${THEME_FONT_SIZE}pt;/" \
+ "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ fi
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/themes/${_pkgname}-${_branch}"
+ cp -a "${srcdir}/${_pkgname}/"* "${pkgdir}/usr/share/themes/${_pkgname}-${_branch}/"
+}