summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-01-10 18:50:06 -0600
committerLuis Martinez2022-01-10 18:56:27 -0600
commit822f5d8c90d960b2138d65f77b7df8372893bae9 (patch)
treebb2c78c59f043b3385db55e453e2d8c3c1447bda
parent4fd8b879b8c3d7d216496aa5ac76b54806558e52 (diff)
downloadaur-822f5d8c90d960b2138d65f77b7df8372893bae9.tar.gz
split package for easier maintenance
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD89
2 files changed, 106 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9673f7c8d3a..4bb261e79b6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,36 @@
pkgbase = nordic-theme
- pkgdesc = GTK theme using the Nord color palette
+ pkgdesc = Nord-derived themes for GTK and other platforms
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/EliverLara/Nordic
arch = any
license = GPL3
source = nordic-theme-2.1.0.tar.xz::https://github.com/EliverLara/Nordic/releases/download/v2.1.0/Nordic.tar.xz
+ source = nordic-standard-buttons-theme-2.1.0.tar.xz::https://github.com/EliverLara/Nordic/releases/download/v2.1.0/Nordic-standard-buttons.tar.xz
+ source = nordic-polar-standard-buttons-theme-2.1.0.tar.xz::https://github.com/EliverLara/Nordic/releases/download/v2.1.0/Nordic-Polar-standard-buttons.tar.xz
+ source = nordic-darker-theme-2.1.0.tar.xz::https://github.com/EliverLara/Nordic/releases/download/v2.1.0/Nordic-darker.tar.xz
+ source = nordic-darker-standard-buttons-theme-2.1.0.tar.xz::https://github.com/EliverLara/Nordic/releases/download/v2.1.0/Nordic-darker-standard-buttons.tar.xz
+ source = nordic-bluish-accent-theme-2.1.0.tar.xz::https://github.com/EliverLara/Nordic/releases/download/v2.1.0/Nordic-bluish-accent.tar.xz
+ source = nordic-bluish-accent-standard-buttons-theme-2.1.0.tar.xz::https://github.com/EliverLara/Nordic/releases/download/v2.1.0/nordic-bluish-accent-standard-buttons.tar.xz
sha256sums = cce429254c31473571963b5125e8fb652ce517bbec5245b1e17fe975b9bfd10b
+ sha256sums = 6f641957eca90598ac8cb7992ea4392cb6ba599d4078d22cc41b04cfd134caea
+ sha256sums = 1dfad784545997cf506982d2764687d320ed95ca527c985a4f6f223dad2acaf8
+ sha256sums = 618643127d063f03ac3d890f74779f4bf070fa4c17ab0f42f97e49c3dc8744fa
+ sha256sums = 2916b6657840022f4bfd3b49b549115da6c79f6a176b38cb3c581bddea44854d
+ sha256sums = 50a508bc8c505ee774bc5e1292f03f237e5d57c9fd3e4be2f0edd7f7bf6c6016
+ sha256sums = 2e11de30494a42458b11a95fe8251982db46e6d6e84362034bdd0b778461a84e
+ sha256sums = 2c87d6c377a74720297c96248ac6a935e9fc11f2199c9cf7785628138ffe0e1b
pkgname = nordic-theme
+
+pkgname = nordic-standard-buttons-theme
+
+pkgname = nordic-polar-standard-buttons-theme
+
+pkgname = nordic-darker-theme
+
+pkgname = nordic-darker-standard-buttons-theme
+
+pkgname = nordic-bluish-accent-theme
+
+pkgname = nordic-bluish-accent-standard-buttons-theme
diff --git a/PKGBUILD b/PKGBUILD
index cb7a70737e66..3bbc43ddca2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,87 @@
# Maintainer: hamki <hamki.do2000@gmail.com>
-# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: happy4pizza
-pkgname=nordic-theme
+pkgname=(
+ nordic-theme
+ nordic-standard-buttons-theme
+ # nordic-polar-theme
+ nordic-polar-standard-buttons-theme
+ nordic-darker-theme
+ nordic-darker-standard-buttons-theme
+ nordic-bluish-accent-theme
+ nordic-bluish-accent-standard-buttons-theme)
pkgver=2.1.0
-pkgrel=1
-pkgdesc="GTK theme using the Nord color palette"
+pkgrel=2
+pkgdesc="Nord-derived themes for GTK and other platforms"
arch=('any')
url="https://github.com/EliverLara/Nordic"
license=('GPL3')
-source=("$pkgname-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic.tar.xz")
-sha256sums=('cce429254c31473571963b5125e8fb652ce517bbec5245b1e17fe975b9bfd10b')
+source=(
+ "nordic-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic.tar.xz"
+ # "nordic-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-v40.tar.xz"
+ "nordic-standard-buttons-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-standard-buttons.tar.xz"
+ # "nordic-standard-buttons-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-standard-buttons-v40.tar.xz"
+ # "nordic-polar-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-Polar.tar.xz"
+ # "nordic-polar-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-Polar-v40.tar.xz"
+ "nordic-polar-standard-buttons-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-Polar-standard-buttons.tar.xz"
+ # "nordic-polar-standard-buttons-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-Polar-standard-buttons-v40.tar.xz"
+ "nordic-darker-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-darker.tar.xz"
+ # "nordic-darker-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-darker-v40.tar.xz"
+ "nordic-darker-standard-buttons-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-darker-standard-buttons.tar.xz"
+ # "nordic-darker-standard-buttons-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-darker-standard-buttons-v40.tar.xz"
+ "nordic-bluish-accent-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-bluish-accent.tar.xz"
+ # "nordic-bluish-accent-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/Nordic-bluish-accent-v40.tar.xz"
+ "nordic-bluish-accent-standard-buttons-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/nordic-bluish-accent-standard-buttons.tar.xz"
+ # "nordic-bluish-accent-standard-buttons-theme-$pkgver.tar.xz::$url/releases/download/v$pkgver/nordic-bluish-accent-standard-buttons-v40.tar.xz")
+)
+sha256sums=('cce429254c31473571963b5125e8fb652ce517bbec5245b1e17fe975b9bfd10b'
+ '6f641957eca90598ac8cb7992ea4392cb6ba599d4078d22cc41b04cfd134caea'
+ '1dfad784545997cf506982d2764687d320ed95ca527c985a4f6f223dad2acaf8'
+ '618643127d063f03ac3d890f74779f4bf070fa4c17ab0f42f97e49c3dc8744fa'
+ '2916b6657840022f4bfd3b49b549115da6c79f6a176b38cb3c581bddea44854d'
+ '50a508bc8c505ee774bc5e1292f03f237e5d57c9fd3e4be2f0edd7f7bf6c6016'
+ '2e11de30494a42458b11a95fe8251982db46e6d6e84362034bdd0b778461a84e'
+ '2c87d6c377a74720297c96248ac6a935e9fc11f2199c9cf7785628138ffe0e1b')
-package() {
- cd Nordic
- find assets cinnamon gnome-shell gtk-* metacity-1 xfwm4 index.theme \
- -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/themes/Nordic/{}" \;
+PURGE_TARGETS=('LICENSE' 'README.md')
+
+_package() {
+ local _name="$1"
+
+ cd "$_name"
+ install -d "$pkgdir/usr/share/themes/$_name/"
+ cp -a --no-preserve=ownership . "$pkgdir/usr/share/themes/$_name/"
+}
+
+package_nordic-theme() {
+ _package "Nordic"
+}
+
+package_nordic-standard-buttons-theme() {
+ _package "Nordic-standard-buttons"
+}
+
+# package_nordic-polar-theme() {
+# _package "Nordic-Polar"
+# }
+
+package_nordic-polar-standard-buttons-theme() {
+ _package "Nordic-Polar-standard-buttons"
+}
+
+package_nordic-darker-theme() {
+ _package "Nordic-darker"
+}
+
+package_nordic-darker-standard-buttons-theme() {
+ _package "Nordic-darker-standard-buttons"
+}
+
+package_nordic-bluish-accent-theme() {
+ _package "Nordic-bluish-accent"
+}
+
+package_nordic-bluish-accent-standard-buttons-theme() {
+ _package "Nordic-bluish-accent-standard-buttons"
}