summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-12-04 01:53:31 -0500
committerTony Lambiris2018-12-04 01:53:31 -0500
commit195b0eb907a4a15c86c2229f3b8639a266a30851 (patch)
tree9c69ef8112bdaa58c3e92509a67daa4c1cdaa2c1
parent8dc0c28c1e81b2c750a6d0935ce692284aadfb1b (diff)
downloadaur-195b0eb907a4a15c86c2229f3b8639a266a30851.tar.gz
Version bump
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD32
2 files changed, 26 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 640659fa807c..0b8162cd4b16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nordic-theme-git
pkgdesc = Dark Gtk3.20+ theme created using the awesome Nord color pallete.
- pkgver = 10.5f31988
+ pkgver = 11.5a5e6e6
pkgrel = 1
url = https://github.com/EliverLara/Nordic
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index c5db7239369c..0d6a3d5b62c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nordic-theme-git
_pkgname=Nordic
-pkgver=10.5f31988
+pkgver=11.5a5e6e6
pkgrel=1
pkgdesc="Dark Gtk3.20+ theme created using the awesome Nord color pallete."
arch=("any")
@@ -23,20 +23,38 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
+ export THEME_FONT_FACE="${THEME_FONT_FACE:-Roboto}"
+ export THEME_FONT_SIZE="${THEME_FONT_SIZE:-10}"
+
msg2 "To customize the font size for gnome-shell, build this pacakge"
- msg2 "with the variable DEFAULT_FONT_SIZE set to the desired pt size"
+ msg2 "with the variables below set to the desired font family and size"
+ msg2 "- THEME_FONT_FACE (default font family is Roboto)"
+ msg2 "- THEME_FONT_SIZE (default font point size is 10)"
msg2 ""
msg2 "Continuing build in 5 seconds..."; sleep 5
- msg2 "Setting gnome-shell font size to ${DEFAULT_FONT_SIZE}pt"
+ msg2 "Setting gnome-shell font face to ${THEME_FONT_FACE}"
+ msg2 "Setting gnome-shell font size to ${THEME_FONT_SIZE}"
+
+ if [ "${THEME_FONT_FACE}" != "Roboto" ]; then
+ sed -i -re "s/font-family: (.*);/font-family: ${THEME_FONT_FACE}, \1;/" \
+ "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ fi
- export DEFAULT_FONT_SIZE="${DEFAULT_FONT_SIZE:-10}"
- sed -i -re "s/font-size: 10pt/font-size: ${DEFAULT_FONT_SIZE:-10}pt/" \
- "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ if [ "${THEME_FONT_SIZE}" != "10" ]; then
+ sed -i -re "s/font-size: (.*);/font-size: ${THEME_FONT_SIZE}pt;/" \
+ "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ fi
msg2 "Rendering assets, please wait"
- cd src
+ pushd gtk-2.0
+ while read $line; do echo -n "."; done < \
+ <(./render-assets.sh; ); echo
+ popd
+
+ pushd src
while read $line; do echo -n "."; done < \
<(./render-gtk3-assets.py; ./render-gtk3-assets-hidpi.py); echo
+ popd
msg2 "Done!"
}