aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland Kiraly2024-06-05 22:27:31 +0100
committerRoland Kiraly2024-06-05 22:27:31 +0100
commit14e768421de1f97674f39ca2c43d1d35fc4d2111 (patch)
treecf1fa03cef7eceb6ea2c1b3476b76ac10c303b5e
parent03019ea02d0b0f244b5455bb14f3b09a96be1a85 (diff)
downloadaur-14e768421de1f97674f39ca2c43d1d35fc4d2111.tar.gz
Update .gitignore and README.md for nordlayer package version 3.2.2
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD2
-rw-r--r--README.md26
-rw-r--r--nordlayer-bin.install (renamed from nordlayer.install)39
5 files changed, 39 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c49b4ad0c035..88d50907b471 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-pkgbase = nordlayer
+pkgbase = nordlayer-bin
pkgdesc = Proprietary VPN client for Linux
pkgver = 3.2.2
pkgrel = 1
url = https://nordlayer.com
- install = nordlayer.install
+ install = nordlayer-bin.install
arch = x86_64
license = custom:commercial
depends = bash
@@ -19,4 +19,4 @@ pkgbase = nordlayer
source_x86_64 = https://downloads.nordlayer.com/linux/latest/debian/pool/main/nordlayer_3.2.2_amd64.deb
sha512sums_x86_64 = f076ae853fb87941d1bc8c7cd34c31d233343a86b1d6b123353c328fda3fd938b7e38741ba1399f63eb2cdda990ddf460fde25e035eb810ea0c3d7de7e5303b2
-pkgname = nordlayer
+pkgname = nordlayer-bin
diff --git a/.gitignore b/.gitignore
index ed46f0304a07..fabb3fdfbf94 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,3 @@
-.idea
pkg
-nordlayer-*
-nordlayer_*
-pkg
-src \ No newline at end of file
+src
+nordlayer_deb
diff --git a/PKGBUILD b/PKGBUILD
index 172103376e96..8c07d4c1a32f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Roland Kiraly <rolandgyulakiraly at outlook dot com>
# https://github.com/raverecursion/nordlayer-latest/tree/master
-pkgname=nordlayer
+pkgname=nordlayer-bin
pkgver=3.2.2
pkgrel=1
pkgdesc="Proprietary VPN client for Linux"
diff --git a/README.md b/README.md
index 98aab8e212af..5ed7e8559742 100644
--- a/README.md
+++ b/README.md
@@ -1,10 +1,13 @@
-# [Nordlayer](https://nordlayer.com) VPN package for Linux (esp [ArchLinux](https://archlinux.org/))
-[![AUR version](https://img.shields.io/aur/version/nordlayer)](https://aur.archlinux.org/packages/nordlayer) [![Nordlayer version](https://img.shields.io/badge/nordlayer-3.1.0-green)](https://nordlayer.com/download/linux/)
+# [Nordlayer](https://nordlayer.com) VPN package for Linux (esp [ArchLinux](https://archlinux.org/))
-### Hotfix (Version 2.6.5) released by Nordlayer
-The new version should not break `nordlayer.db`
+[![AUR version](https://img.shields.io/aur/version/nordlayer)](https://aur.archlinux.org/packages/nordlayer-bin) [![Nordlayer version](https://img.shields.io/badge/nordlayer-3.1.0-green)](https://nordlayer.com/download/linux/)
+
+### Hotfix (Version 3.2.2) released by Nordlayer
+
+The new version should not break `nordlayer.db`
If you're still facing issues afterwards - repeat 2.6.4 version fix
+
```sh
rm /var/lib/nordlayer/nordlayer.db
systemctl restart nordlayer
@@ -12,28 +15,35 @@ nordlayer login
```
### Important
-If you run into any errors feel free to create an [issue](https://github.com/Sidicer/nordlayer/issues/new) or leave a comment [in AUR](https://aur.archlinux.org/packages/nordlayer)
+
+If you run into any errors feel free to create an [issue](https://github.com/raverecursion/nordlayer-latest/issues/new) or leave a comment [in AUR](https://aur.archlinux.org/packages/nordlayer-bin)
To check latest official [nordlayer](https://nordlayer.com) version:
+
```sh
curl https://downloads.nordlayer.com/linux/latest/version -w "\n"
```
+
---
+
### Installing Nordlayer from AUR:
+
```sh
-yay -S nordlayer
+yay -S nordlayer-bin
```
### Building the package manually:
+
```sh
-git clone https://github.com/akumaburn/nordlayer-latest.git
+git clone https://github.com/raverecursion/nordlayer-latest.git
cd nordlayer-latest
makepkg -si
# If 'makepkg -si' fails to install automatically:
-sudo pacman -U nordlayer-3.1.0-0-x86_64.pkg.tar.zst
+sudo pacman -U nordlayer-bin-3.2.2-1-x86_64.pkg.tar.zst
```
### Connection Error fix:
+
```
sudo usermod -a -G nordlayer $(whoami)
sudo setcap 'CAP_NET_ADMIN=+eip' /usr/libexec/nordlayer/nordlayer-charon
diff --git a/nordlayer.install b/nordlayer-bin.install
index 18d381b92c9b..9afd32e0d27b 100644
--- a/nordlayer.install
+++ b/nordlayer-bin.install
@@ -6,36 +6,29 @@ post_install() {
setcap CAP_NET_BIND_SERVICE,CAP_NET_ADMIN,CAP_NET_RAW+eip /usr/bin/nordlayerd
setcap CAP_NET_BIND_SERVICE,CAP_NET_ADMIN,CAP_NET_RAW+eip /usr/libexec/nordlayer/nordlayer-openvpn
- groupadd -r -f nordlayer
- groupadd -r -f nordlayer-resolve
+ # Create necessary groups
+ getent group nordlayer || groupadd -r nordlayer
+ getent group nordlayer-resolve || groupadd -r nordlayer-resolve
- if ! id "nordlayer" >/dev/null 2>&1; then
- useradd -s /usr/bin/nologin -c "Used for running NordLayer" -r -M -d /run/nordlayer -g nordlayer nordlayer
+ # Create nordlayer user if it does not exist
+ if ! id "nordlayer" &>/dev/null; then
+ useradd -r -M -d /run/nordlayer -s /usr/bin/nologin -c "Used for running NordLayer" -g nordlayer nordlayer
fi
usermod -a -G nordlayer-resolve nordlayer
- mkdir -p ${VAR_LIB}
- chmod 0770 -R ${VAR_LIB}
- chown nordlayer:nordlayer -R ${VAR_LIB}
-
+ # Setup directories and permissions
+ install -d -m 0770 -o nordlayer -g nordlayer ${VAR_LIB}
chown root:nordlayer-resolve ${NORDLAYER_RESOLVCONF}
chmod 4750 ${NORDLAYER_RESOLVCONF}
- # Ensure nordlayer-resolvconf has execute permissions
chmod +x ${NORDLAYER_RESOLVCONF}
- # Reload config
- systemctl daemon-reload
- # Create tmpfiles
+ # Reload systemd and create tmpfiles
+ systemctl daemon-reload
systemd-tmpfiles --create
- # Start service on boot
- systemctl enable nordlayer.socket
- systemctl enable nordlayer.service
-
- # Restart service now
- systemctl start nordlayer.socket
- systemctl start nordlayer.service
+ # Enable and start the service and socket
+ systemctl enable --now nordlayer.service nordlayer.socket
# Add current user to nordlayer group
current_user=$(logname)
@@ -52,10 +45,8 @@ post_upgrade() {
}
pre_remove() {
+ # Disable and stop the service and socket
+ systemctl disable --now nordlayer.service nordlayer.socket
+ # Remove the directory
rm -rf ${VAR_LIB}
- systemctl disable nordlayer.service
- systemctl disable nordlayer.socket
-
- systemctl stop nordlayer.service
- systemctl stop nordlayer.socket
}