summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Morr2015-06-24 22:28:22 +0200
committerSebastian Morr2015-06-24 22:28:22 +0200
commit27ee4c8b9de1420120de6dac2ee19fc8681c523d (patch)
tree4582f04d64374891d4c0764f84fd4f7619ce01e3
downloadaur-27ee4c8b9de1420120de6dac2ee19fc8681c523d.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd0d3178d974
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nordlicht
+ pkgdesc = Creates colorful moviebarcodes from video files, comes with a shared C library
+ pkgver = 0.3.5
+ pkgrel = 2
+ url = http://github.com/nordlicht/nordlicht
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = help2man
+ depends = ffmpeg
+ depends = libpng
+ depends = popt
+ source = https://github.com/nordlicht/nordlicht/archive/v0.3.5.tar.gz
+ md5sums = 0d9da375be20b0722f7ae15f3974c37a
+
+pkgname = nordlicht
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d696a189c498
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Sebastian Morr <sebastian@morr.cc>
+
+pkgname=nordlicht
+pkgver=0.3.5
+pkgrel=2
+pkgdesc="Creates colorful moviebarcodes from video files, comes with a shared C library"
+arch=('i686' 'x86_64')
+url="http://github.com/nordlicht/nordlicht"
+license=('GPL')
+depends=('ffmpeg' 'libpng' 'popt')
+makedepends=('git' 'cmake' 'help2man')
+source=(https://github.com/nordlicht/$pkgname/archive/v$pkgver.tar.gz)
+md5sums=('0d9da375be20b0722f7ae15f3974c37a')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}