summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume BOEHM2024-04-15 14:38:21 +0200
committerGuillaume BOEHM2024-04-15 14:38:21 +0200
commitfe9536e8f4309b748f6a246608ef68e4c5970adf (patch)
tree0fac11f08793252b05d0e2e2d80e9821db2f99e4
downloadaur-fe9536e8f4309b748f6a246608ef68e4c5970adf.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bafe382969b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nordzy-cursors-hyprcursor
+ pkgdesc = Hyprcursor port of https://github.com/alvatip/Nordzy-cursors.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/guillaumeboehm/Nordzy-cursors-hyprcursor
+ arch = any
+ license = GPL3
+ noextract = Nordzy-cursors-hyprcursor.tar.gz
+ noextract = Nordzy-cursors-white-hyprcursor.tar.gz
+ source = https://github.com/guillaumeboehm/Nordzy-cursors-hyprcursor/releases/download/1.0.0/Nordzy-cursors-hyprcursor.tar.gz
+ source = https://github.com/guillaumeboehm/Nordzy-cursors-hyprcursor/releases/download/1.0.0/Nordzy-cursors-white-hyprcursor.tar.gz
+ sha256sums = 8b3f47d997a2dba1d9711e471e5e1a762b0b621e6003c6082a68cc0abeca0c02
+ sha256sums = 80faf7deff6fed660f17a40c90ed650606641ba8a33570632636ef05d89bafa2
+
+pkgname = nordzy-cursors-hyprcursor
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c06b691ffbaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Guillaume BOEHM <aur@gboehm.com>
+pkgname=nordzy-cursors-hyprcursor
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Hyprcursor port of https://github.com/alvatip/Nordzy-cursors."
+arch=(any)
+url="https://github.com/guillaumeboehm/Nordzy-cursors-hyprcursor"
+license=('GPL3')
+source=(
+ "https://github.com/guillaumeboehm/Nordzy-cursors-hyprcursor/releases/download/${pkgver}/Nordzy-cursors-hyprcursor.tar.gz"
+ "https://github.com/guillaumeboehm/Nordzy-cursors-hyprcursor/releases/download/${pkgver}/Nordzy-cursors-white-hyprcursor.tar.gz"
+)
+noextract=("${source[@]##*/}")
+sha256sums=(
+ "8b3f47d997a2dba1d9711e471e5e1a762b0b621e6003c6082a68cc0abeca0c02"
+ "80faf7deff6fed660f17a40c90ed650606641ba8a33570632636ef05d89bafa2"
+)
+
+package() {
+ install -dm755 "${pkgdir}/usr/share/icons/Nordzy-cursors-hyprcursor"
+ install -dm755 "${pkgdir}/usr/share/icons/Nordzy-cursors-white-hyprcursor"
+
+ tar --no-same-owner -zxvf Nordzy-cursors-hyprcursor.tar.gz -C "${pkgdir}/usr/share/icons/"
+ tar --no-same-owner -zxvf Nordzy-cursors-white-hyprcursor.tar.gz -C "${pkgdir}/usr/share/icons/"
+}