summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Escoz2018-08-05 15:40:25 +0200
committerDaniel Escoz2018-08-05 15:42:22 +0200
commit329efeb63f9e9946795e806e8535ce0e28bd5c90 (patch)
tree30ad65975e64d395f660a63e805cde94eaf0f22d
downloadaur-329efeb63f9e9946795e806e8535ce0e28bd5c90.tar.gz
First apparently working version
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1582ecff4dbd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nosqlbooster-mongodb
+ pkgdesc = Shell-centric GUI tool for MongoDB
+ pkgver = 4.7.0
+ pkgrel = 1
+ url = https://nosqlbooster.com
+ arch = x86_64
+ license = GPL
+ depends = gconf
+ depends = libnotify
+ depends = libxss
+ depends = libxtst
+ noextract = nsqlb4m.AppImage
+ source = nsqlb4m.AppImage::https://nosqlbooster.com/s3/download/releasesv4/nosqlbooster4mongo-4.7.0.AppImage
+ md5sums = da91339b27d5bdccc404fbdc47c41839
+ sha1sums = 78717b7308c16734623b2be38a822825416e7b0f
+ sha256sums = 4fe6dad993aefbcb1ab47848e8c8c3085873eed0e18370d12e28bccedb9158be
+
+pkgname = nosqlbooster-mongodb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b3cb796b24c3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg.tar.*
+*.AppImage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69f46f0a1405
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Daniel Escoz <darkhogg+aur.nosqlbooster-mongodb@gmail.com>
+pkgname=nosqlbooster-mongodb
+pkgver=4.7.0
+pkgrel=1
+pkgdesc="Shell-centric GUI tool for MongoDB"
+arch=('x86_64')
+url="https://nosqlbooster.com"
+license=('GPL')
+depends=(gconf libnotify libxss libxtst)
+makedepends=()
+optdepends=()
+source=(nsqlb4m.AppImage::https://nosqlbooster.com/s3/download/releasesv4/nosqlbooster4mongo-4.7.0.AppImage)
+noextract=(nsqlb4m.AppImage)
+md5sums=('da91339b27d5bdccc404fbdc47c41839')
+sha1sums=('78717b7308c16734623b2be38a822825416e7b0f')
+sha256sums=('4fe6dad993aefbcb1ab47848e8c8c3085873eed0e18370d12e28bccedb9158be')
+
+build() {
+ cd "$srcdir"
+
+ chmod +x nsqlb4m.AppImage
+ ./nsqlb4m.AppImage --appimage-extract
+
+ chmod +x 'squashfs-root/app/nosqlbooster4mongo'
+
+ sed -E \
+ -e '/X-/d' \
+ -e 's#^Exec=.*$#Exec=/opt/nosqlbooster-mongodb/nosqlbooster4mongo#' \
+ -i 'squashfs-root/nosqlbooster4mongo.desktop'
+}
+
+package() {
+ cd "$srcdir"
+
+ install -d "${pkgdir}/usr"
+ cp -r "squashfs-root/usr/share" "${pkgdir}/usr/share"
+
+ install -d "${pkgdir}/opt"
+ cp -r "squashfs-root/app" "${pkgdir}/opt/nosqlbooster-mongodb"
+
+ install -D 'squashfs-root/nosqlbooster4mongo.desktop' "${pkgdir}/usr/share/applications/nosqlbooster4mongo.desktop"
+ find "$pkgdir" -type d -exec chmod 755 {} +
+}