summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-05-14 16:08:53 +0200
committerPhilip Goto2021-05-14 16:08:53 +0200
commitdf995136f0f467eb74912a65fce2b05f1d7a6440 (patch)
tree9e522bdde621c8b30012771cd22d106d3d6e03b0
downloadaur-df995136f0f467eb74912a65fce2b05f1d7a6440.tar.gz
Initialize
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fea13eb544c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = nostalgia-git
+ pkgdesc = Set historic GNOME wallpapers
+ pkgver = 0.6.r3.gce88525
+ pkgrel = 1
+ url = https://gitlab.gnome.org/bertob/nostalgia
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = vala
+ depends = libhandy
+ provides = nostalgia
+ conflicts = nostalgia
+ source = git+https://gitlab.gnome.org/bertob/nostalgia.git
+ sha256sums = SKIP
+
+pkgname = nostalgia-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e94e02afe8a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=nostalgia-git
+pkgver=0.6.r3.gce88525
+pkgrel=1
+pkgdesc='Set historic GNOME wallpapers'
+arch=(x86_64 aarch64)
+url='https://gitlab.gnome.org/bertob/nostalgia'
+license=(GPL3)
+provides=(nostalgia)
+conflicts=(nostalgia)
+depends=(libhandy)
+makedepends=(
+ git
+ gobject-introspection
+ meson
+ vala
+)
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+build() {
+ arch-meson nostalgia build
+ meson compile -C build
+}
+
+pkgver() {
+ cd nostalgia
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir/" meson install -C build
+}