summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2020-09-04 19:44:12 -0600
committergustawho2020-09-04 19:44:12 -0600
commited731107902049f681bd35e8a4e8cc8ff4cc3d90 (patch)
tree2ec8823ac4bceb74f97f36a84812bc1dba2c8064
parentb678c669815db54151f6741bf504663a3a4ca27f (diff)
downloadaur-ed731107902049f681bd35e8a4e8cc8ff4cc3d90.tar.gz
Pushed for latest git changes
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c25914080044..8948b2393f58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
pkgbase = nota-git
- pkgdesc = Simple Text Editor for KDE
- pkgver = r166.7d70269
+ pkgdesc = Multi-platform text editor
+ pkgver = v1.1.1.r17.gd50e906
pkgrel = 1
url = https://vvave.kde.org/
arch = x86_64
license = GPL3
makedepends = git
- makedepends = cmake
makedepends = extra-cmake-modules
- makedepends = syntax-highlighting
- makedepends = appstream
depends = ki18n
depends = knotifications
- depends = qt5-quickcontrols2
depends = qt5-svg
depends = kio
depends = mauikit-git
depends = kirigami2
+ depends = syntax-highlighting
provides = nota
conflicts = nota
- source = git+https://invent.kde.org/kde/nota.git
+ source = git+https://invent.kde.org/maui/nota.git
sha256sums = SKIP
pkgname = nota-git
diff --git a/PKGBUILD b/PKGBUILD
index f7c8b0cedaa7..631f2f74d732 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: Stoian Minaev
-
+# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
+
pkgname=nota-git
-pkgver=r166.7d70269
+pkgver=v1.1.1.r17.gd50e906
pkgrel=1
-pkgdesc="Simple Text Editor for KDE"
+pkgdesc="Multi-platform text editor"
arch=(x86_64)
url="https://vvave.kde.org/"
-license=(GPL3)
-depends=(ki18n knotifications qt5-quickcontrols2 qt5-svg kio mauikit-git kirigami2)
-makedepends=(git cmake extra-cmake-modules syntax-highlighting appstream)
-provides=(nota)
-conflicts=(nota)
-source=("git+https://invent.kde.org/kde/nota.git")
+license=('GPL3')
+depends=('ki18n' 'knotifications' 'qt5-svg' 'kio' 'mauikit-git' 'kirigami2' 'syntax-highlighting')
+makedepends=('git' 'extra-cmake-modules')
+provides=('nota')
+conflicts=('nota')
+source=("git+https://invent.kde.org/maui/nota.git")
sha256sums=('SKIP')
pkgver() {
@@ -24,16 +24,21 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
- install -d build
+ mkdir build
}
build() {
cd "${pkgname%-git}/build"
- cmake ..
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
make
}
package() {
cd "${pkgname%-git}/build"
+ install -d "$pkgdir/usr/share/icons/hicolor/scalable/apps"
+ install -Dm644 ../src/assets/nota.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/maui-nota.svg"
make DESTDIR="$pkgdir" install
}