summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReik Keutterling2017-11-24 15:12:04 +0100
committerReik Keutterling2017-11-24 15:12:04 +0100
commit10c52e959253185fbf20da967ae8706f6f987f7b (patch)
tree1f28c344440800eb42ddd390a376838f4df40df0
downloadaur-10c52e959253185fbf20da967ae8706f6f987f7b.tar.gz
initial version of notary (git version) package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb88b6f9eeaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = notary-git
+ pkgdesc = Notary is a project that allows anyone to have trust over arbitrary collections of data.
+ pkgver = 0.5.0.r295.ga41821fe
+ pkgrel = 1
+ url = https://github.com/theupdateframework/notary
+ arch = x86_64
+ license = APACHE
+ makedepends = git
+ makedepends = go
+ makedepends = godep
+ provides = notary=0.5.0.r295.ga41821fe
+ conflicts = notary-bin
+ options = !strip
+ options = !emptydirs
+ source = notary-git::git://github.com/theupdateframework/notary.git
+ sha256sums = SKIP
+
+pkgname = notary-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa3b52989676
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Reik Keutterling <spielkind@gmail.com>
+pkgname=notary-git
+pkgver=0.5.0.r295.ga41821fe
+pkgrel=1
+pkgdesc="Notary is a project that allows anyone to have trust over arbitrary collections of data."
+arch=('x86_64')
+url="https://github.com/theupdateframework/notary"
+license=('APACHE')
+makedepends=('git' 'go' 'godep')
+provides=(${pkgname%-*}=$pkgver)
+conflicts=(${pkgname%-*}-bin)
+options=('!strip' '!emptydirs')
+source=($pkgname::git://github.com/theupdateframework/${pkgname%-*}.git)
+sha256sums=('SKIP')
+
+_gourl=github.com/theupdateframework/notary
+_gobuild=build/src/$_gourl
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p "$(dirname $_gobuild)"
+ cp -a "$srcdir/$pkgname" $_gobuild
+}
+
+build() {
+ cd $_gobuild
+ GOPATH="$srcdir/build" make client
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install -Dm755 $srcdir/$_gobuild/bin/notary $pkgdir/usr/bin/notary
+}